1

My compiler is flagging an error but everything seems to be working correctly. Can anyone help me understand the problem?

\documentclass{beamer}
\usetheme[progressbar=frametitle]{metropolis}
\setbeamertemplate{frame numbering}[fraction]
\useoutertheme{metropolis}
\useinnertheme{metropolis}
%\usefonttheme{metropolis}
\usecolortheme{spruce}
\setbeamercolor{background canvas}{bg=white}
\usepackage{kpfonts}
\usepackage{amsmath}
\definecolor{mygreen}{rgb}{.125,.5,.25}
\title{Understanding the MIDI Function}
\usepackage{cases}
\date{}
\begin{document}
\metroset{block=fill}

\begin{frame}
\titlepage
\end{frame}

\begin{frame}[t]{Examining the Function} \vspace{10pt}
\begin{block}{MIDI Function}
\begin{align*}

\mathsf{f(s) &= 440 \cdot 2^{\frac{(s-29)}{12}}}\\
\text{$s$ is the MIDI Number.}\\
\mathsf{f(s) &= 440 \cdot e^{(s-29)} \cdot \frac{\log{2}}{12}}

\end{align*}
\end{block}
\vspace{10pt}

\vspace{10pt}
\begin{block}{MIDI Number}

  \[ \mathsf{s=\frac{12}{\sqrt{2}} \cdot \log\left(\frac{f}{440}\right)+29}\]

\end{block}

\end{frame} < - error ! Missing } inserted. <inserted text>} \end{frame}


\end{document}
8
  • 2
    you can not have a blank line in align Nov 20, 2021 at 15:23
  • 2
    your code gives the error ! Paragraph ended before \align* was complete. because of the blank lines in the source. Nov 20, 2021 at 15:30
  • 1
    that error just delete the blank line the error for } is due to \mathsf{f(s) & you need to close the \mathsf before the & Nov 20, 2021 at 15:33
  • 1
    \mathsf{f}(\mathsf{s}) or \mathsf{f(s)} but I prefer the first of these. Nov 20, 2021 at 15:46
  • 4
    I’m voting to close this question because solved in comments?! Jan 8, 2022 at 3:33

0

Browse other questions tagged .