0

I tried using some of the solutions posted on this forum for wrapping text in WinEdt for my .bib files, but what I tried so far does not work.

I tried selecting the "Wrap" option at the bottom of the GUI:

enter image description here

Also, adding "BIB" to the preferences option and selecting "Wrap Soft Comments":

enter image description here

These options that I tried still does not wrap the text for my ".bib" files.

Can you tell me what is the solution to wrap the text for the .bib files in WinEdt 10.3 in the Windows 10 environment? Thanks!

7
  • 1
    You probably need to add "BIB" to the modes for soft wrapping as well, but this is just my guess. Nov 22 '21 at 23:35
  • @JasperHabicht, I tried that but I still cannot get the lines to wrap.
    – Joe
    Nov 23 '21 at 2:06
  • 1
    I am doing this from my mind without testing, but when I am not mistaken the value of "Enable Wrapping for Modes" consists of two parts. The ones left of | states to activate wrapping and the ones right of | states to deactivate wrapping. So my suggestion would be to move BIB before the |, i.e. after ASCII. Nov 24 '21 at 15:24
  • 1
    @Joe, did my comment solve your problem or do you need further assistance? Nov 30 '21 at 10:17
  • 1
    For the (later) wrapping you can use the bibMacros AddOn ... Nov 30 '21 at 14:07
1
+50

As already stated in the comment below the question the text fields in the shown screenshot of the Wrapping options comprise of two parts. The part left of the separator | which enables (soft) wrapping and the part right of the separator | which disables (soft) wrapping.

Said that by adding BIB as the last item of the upper text field, which is right of | you in fact disabled wrapping. Simply move it before (left of) | and it should work as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.