0

I'm trying to make a Memoir chapter style based on veelo, using this custom definition:

\documentclass[a5paper]{memoir}
\usepackage[utf8]{inputenc}

\usepackage{lipsum}
\usepackage{graphicx}
\usepackage[showframe]{geometry}

\newlength{\numberheight}
\setlength{\numberheight}{15mm}
\makechapterstyle{myveelo}{%
    \setlength{\afterchapskip}{30pt}
    \renewcommand*{\chapterheadstart}{\vspace*{10pt}}
    \renewcommand*{\afterchapternum}{\par\nobreak\vskip 10pt}
    \renewcommand*{\chapnumfont}{\normalfont\Huge\bfseries}
    \renewcommand*{\chaptitlefont}{\normalfont\Huge\bfseries}
    \renewcommand*{\printchaptername}{}
    \renewcommand*{\chapternamenum}{}
    \renewcommand*{\printchapternum}{%
        \makebox[0pt][l]{%
            \resizebox{!}{\numberheight}{\chapnumfont\thechapter}%
        }%
        \makebox[0pt][l]{%
            \hspace{\textwidth}%
            \hspace{1.5cm}%
            \rule{2cm}{\numberheight}%
        }
    }%
    \makeoddfoot{plain}{}{}{\thepage}
}

\chapterstyle{myveelo}

\begin{document}
\chapter{Introduction}
\lipsum[1]
\end{document}

An example chapter made with this (with showframe from the geometry package):

enter image description here

The problem is that the number is not aligned, and that the offset depends on the chapter number (1 is quite large, 4 is much smaller, etc.). Is there a way to left-align the number automatically for all chapter numbers?

1
  • Please complete your snippet to a complete compilable example, starting with \documentclass and ending with \end{document}. Another comment, in your snippet you don't need \makeatletter and \makeatother since you are not using internal commands (containing @) Nov 25 at 23:58
0

Too long for a comment. This has nothing to do with memoir but rather a part of the font as can be seen from this example

\documentclass[a4paper]{memoir}
\newcommand\Show[1]{%
  \begingroup%
  \fboxsep=0pt%
  \fbox{#11}%
  \endgroup%
  \par\medskip
}
\begin{document}
\Show{}
\Show{\large}
\Show{\Large}
\Show{\LARGE}
\Show{\huge}
\Show{\Huge}
\end{document}

The box around the number does not fit snugly and the effect is more noticeable as the font size gets larger

enter image description here

4
  • So I suppose this means there is no solution then? Or is there a way to get the size of the number rather than the box, so I can offset the number to align nicely?
    – Martin
    Nov 26 at 9:24
  • @Martin I usually do some tests with various numbers an then apply a negative kern to get it to the right place. There might be other methods.
    – daleif
    Nov 26 at 9:34
  • @Martin chat mentions tex.stackexchange.com/questions/316964/… and tex.stackexchange.com/questions/470276/… though they probably need xelatex or lualatex
    – daleif
    Nov 26 at 10:36
  • The digits in Computer Modern (and many other fonts) are monospace so that they align nicely in tables. Some fonts have a second set of digits that is spaced more like text. (And then there is the old style design, which can also come with two spacing settings.) These are all design decisions, and depend on the intended use. Numbers are not simple. Nov 26 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.