I updated every package with MiKTeX console today (Dec. 7, 2021), and now I have issues compiling with XeLaTeX any document that uses \setmainfont or \fontspec, but loading the fontspec package works fine. Sometimes they work, but usually not, and I have not been able to determine under which condition they work. Deleting the auxilary files doesn't change anything; I thought I could produce a pdf when not using synctex as a command option but it seems not to always work either. I tried reinstalling fontspec already. Trying to compile the .tex file, it leaves me with a either empty or incomplete .log file, and a .synctex(busy) file. It tends to crash after reaching fontspec.cfg.

Here's is a MWE of what is causing me issues:

\setmainfont{Latin Modern Roman}

Hello World!

Try this thing?

\IfFontExistsTF{Latin Modern Roman}{T}{F}

\IfFontExistsTF{Times New Roman}{T}{F}



At some point it worked when commenting out \setmainfont but now it doesn't unless also commenting out \fontspec. The pdf produced still contains "T" for the three \IfFontExistsTF.

Sorry if there are details missing but I really don't know what more to look for and that is the best I could troobleshoot it. I could send a list of the packages that were updated if that could be helpful.

  • (1) Do you get any errors? Can you provide a log file (update your question with it). (2) Does your miktex console have two modes? (miktex user and miktex admin) did you update in both?
    – daleif
    Dec 8, 2021 at 8:38
  • you are not alone. It crashes for me too. Dec 8, 2021 at 9:03
  • 1
    lualatex works fine, and loading fonts by file name too. It crashes for xelatex + font names. I opened an issue here github.com/MiKTeX/miktex/issues/984 Dec 8, 2021 at 10:13
  • No crash with my TeX Live.
    – egreg
    Dec 8, 2021 at 10:39
  • Similar issue happens when trying to use Arabic language in XeLaTeX github.com/MiKTeX/miktex/issues/994 Dec 9, 2021 at 15:15

1 Answer 1


This is a due to bug in the miktex xetex binary. It has been reported here


As a work-around use lualatex.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .