0

Now I'm using mtpro2 lite font but when I use the code "\leqslant", I do not get the symbol of mtpro2: enter image description here, I got the normal symbol of Ams. Can somebody tell me how can I get the symbol of mtpro2? Thank you.

\documentclass[12pt, a4paper]{book}
\usepackage[utf8]{vietnam}
\usepackage[lite]{mtpro2}
\usepackage[left=1.6cm, right=1.6cm, top=1.3cm, bottom=0cm ]{geometry}
\renewcommand{\rmdefault}{ptm}
\setlength{\parindent}{0pt}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\pagestyle{plain}
\begin{document}
....
\end{document}
1
  • 1
    Not without you showing us a sample document. We don't know how you set up your preamble
    – daleif
    Commented Dec 11, 2021 at 13:32

1 Answer 1

1

In order to get \leqslant from MTPro2, you need

  1. the full version (paid), not lite
  2. to call \usepackage[amssymbols]{mtpro2}

So with the lite version you can only get the symbol from amssymb, if you really want it.

Let's see why; here is how \leqslant is defined in mtpro2.sty:

   1391 \DeclareMathSymbol{\leqslant}     {\mathrel}{AMSa}{"36}

(line numbers are used for reference). This line of code appears under the scope of

   1306 \ifmtp@ams

and we find

     29 \newif\ifmtp@ams
     30 \DeclareOption{noamssymbols}{\mtp@amsfalse}
     31 \DeclareOption{amssymbols}{\ifmtp@full\mtp@amstrue\else\mtp@opterr\fi}

So \ifmtp@ams is set to true only if \ifmtp@full is set to true, which is not with the lite option:

     22 \DeclareOption{lite}{\mtp@fullfalse\mtp@amsfalse}

If you have the full version of mtpro2, you load neither amsfonts nor amssymb.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .