4

At some point in the past week or so, tex4ht seems to have stopped working on my computer. I now get this error when I run it while trying to convert from tex to odt:

[ERROR]   htlatex: ?    ?    Emergency stop.
[FATAL]   make4ht-lib: Fatal error. Command htlatex returned exit code 1
Error: source file could not be loaded

The bash command that generated this error was:

make4ht -ux -f odt  -c $configfile $filename.out.tex

where $configfile is myconfig.cfg:

\Preamble{xhtml,ooffice}
\ConfigureOO{Footnote}{
<style:style
    style:name="Footnote"
    style:family="paragraph"
    style:parent-style-name="Standard"
    style:class="extra">\Hnewline
  <style:paragraph-properties
             fo:margin-left="0in"
             fo:margin-right="0in"
             fo:text-indent="0.1in"
              style:auto-text-indent="false"/>
  <style:text-properties fo:font-size="83.3333333333333333333333\%"
      style:font-size-asian="83.3333333333333333333333\%"
      style:font-size-complex="83.3333333333333333333333\%" />
</style:style>\Hnewline
<text:notes-configuration text:note-class="footnote"
    text:citation-style-name="Footnote_20_Symbol"
    text:citation-body-style-name="Footnote_20_anchor"
    style:num-format="1" text:start-value="0"
    text:footnotes-position="page"
    text:start-numbering-at="document" />\Hnewline
<style:style style:name="Footnote_20_Symbol"
style:display-name="Footnote Symbol" style:family="text" >\Hnewline
  <style:text-properties style:text-position="super 58\%" />\Hnewline
</style:style>
<style:style style:name="Footnote_20_anchor"
style:display-name="Footnote anchor" style:family="text">
  <style:text-properties style:text-position="super 58\%" />\Hnewline
</style:style>\Hnewline
}

\ConfigureOO{verse}{\Hnewline
<style:style style:name="verse"
             style:family="paragraph"
             style:parent-style-name="Text-body"
             style:next-style-name="Text-body">
<style:paragraph-properties  fo:margin-left="1.499cm"
             fo:margin-right="1cm"
             fo:margin-top="0cm"
             fo:margin-bottom="0cm"
             fo:text-indent="-0.499cm"
             style:auto-text-indent="false">
   <style:tab-stops/>
</style:paragraph-properties >
</style:style>
\Hnewline}

\def\loopoverdigits#1{\ifx\relax#1\else%
% Unicode block for Arabic numerals starts at U+0660
% the following special command inserts the XML entity
% for the number, which will be converted to Unicode char
% by tex4ht
\special{t4ht@+&{35}x066#1{59}}x%
\expandafter\loopoverdigits\fi}

\def\arabicdigits#1{\NoFonts\loopoverdigits#1\relax\EndNoFonts}
\ifdefined\xeuniuseblock
\xeuniuseblock{Greek}
\xeuniuseblock{Arabic}
\fi
\makeatletter
\ConfigureEnv{arab}{\@rltrue}{\@rlfalse}{}{}
\Configure{ref}{\Link}{\EndLink}{}
\makeatother
\begin{document}
\EndPreamble

The last time I used tex4ht successfully without this error was on December 14. I think that after that was when I did a routine texlive update, which probably included tex4ht. (I just checked now, December 22, and it looks like I am still up to date with the latest tex4ht.)

How can I fix this?

Update

I've played around a bit more with it and found that the error goes away with a minimal example, suggesting the problem lies somewhere in my configuration or the project I am working on at the moment.

But when I use Git to rewind to before my last successful ODT-compilation, the error does not go away, suggesting that some change to tex4ht code is part of the problem.

Update 2

I have not yet managed to put together a MWE that reproduces the error. But I have noticed that the import package may have something to do with what is going on: the previously lines in the terminal output before the fatal error seem to suggest that filepaths are being incorrectly expanded:

[ERROR]   htlatex: ..//sections/0-intro.tex 67   Argument of \etb@tgl@blx@usenamea has an extra }.
[ERROR]   htlatex: ..//sections/0-intro.tex 67   Paragraph ended before \etb@tgl@blx@usenamea was complete.
[ERROR]   htlatex: ..//sections/0-intro.tex 67   Missing number, treated as zero.
[ERROR]   htlatex: ..//sections/0-intro.tex 67   Missing = inserted for \ifnum.
[ERROR]   htlatex: ..//sections/0-intro.tex 67   Missing number, treated as zero.
[ERROR]   htlatex: ./_lists-M-front-matter-WORD 8    Undefined control sequence.
[ERROR]   htlatex: ./_lists-M-front-matter-WORD 26   Undefined control sequence.
[ERROR]   htlatex: ./_lists-M-front-matter-WORD 27   Undefined control sequence.
[ERROR]   htlatex: ./_lists-M-front-matter-WORD 28   Undefined control sequence.
[ERROR]   htlatex: ./_lists-M-front-matter-WORD 29   Undefined control sequence.
[ERROR]   htlatex: ./_lists-M-front-matter-WORD 30   Undefined control sequence.
[ERROR]   htlatex: ./_lists-M-front-matter-WORD 31   Undefined control sequence.
[ERROR]   htlatex: ?    ?    Emergency stop.
[FATAL]   make4ht-lib: Fatal error. Command htlatex returned exit code 1

Note that ..//sections/0-intro.tex should of course be ../sections/0-intro.tex with no double-slash.

In my main tex file, I call all of the actual content of the document with an \import command:

\import{..}{_outline}

_outline.tex has some title information and then \input{sections-compiled-by-Makefile}. My Makefile automatically makes this file from the sections files in a directory called sections/. The file sections-compiled-by-Makefile.tex in this case reads:

\input{sections/0-intro.tex}
\input{sections/1-TOC.tex}
\input{sections/2-Table-of-Signs.tex}
\input{sections/3-List-of-Authors.tex}
\input{sections/z1-Conclusion.tex}
\input{sections/z2-Acknowledgments.tex}

As far as I can tell, I am using \import and \input commands properly. It works to compile using xelatex. The problem comes with make4ht.

Did anything about how make4ht implements the import package change that could have added a spurious extra slash?

Update 3

Well, now I've noticed that a few lines further up in the terminal output is a line about too many }'s:

[ERROR]   htlatex: ..//sections/0-intro.tex 57   Missing number, treated as zero.
[ERROR]   htlatex: ..//sections/0-intro.tex 57   Missing } inserted.
[ERROR]   htlatex: ..//sections/0-intro.tex 57   Extra \endgroup.
[ERROR]   htlatex: ..//sections/0-intro.tex 57   Too many }'s.
[ERROR]   htlatex: ..//sections/0-intro.tex 67   Missing number, treated as zero.
[ERROR]   htlatex: ..//sections/0-intro.tex 67   Missing = inserted for \ifnum.
[ERROR]   htlatex: ..//sections/0-intro.tex 67   Missing number, treated as zero.
[ERROR]   htlatex: ..//sections/0-intro.tex 67   Argument of \etb@tgl@blx@usenamea has an extra }.
[ERROR]   htlatex: ..//sections/0-intro.tex 67   Paragraph ended before \etb@tgl@blx@usenamea was complete.
[ERROR]   htlatex: ..//sections/0-intro.tex 67   Missing number, treated as zero.
[ERROR]   htlatex: ..//sections/0-intro.tex 67   Missing = inserted for \ifnum.
[ERROR]   htlatex: ..//sections/0-intro.tex 67   Missing number, treated as zero.
[ERROR]   htlatex: ./_lists-M-front-matter-WORD 8    Undefined control sequence.
[ERROR]   htlatex: ./_lists-M-front-matter-WORD 26   Undefined control sequence.
[ERROR]   htlatex: ./_lists-M-front-matter-WORD 27   Undefined control sequence.
[ERROR]   htlatex: ./_lists-M-front-matter-WORD 28   Undefined control sequence.
[ERROR]   htlatex: ./_lists-M-front-matter-WORD 29   Undefined control sequence.
[ERROR]   htlatex: ./_lists-M-front-matter-WORD 30   Undefined control sequence.
[ERROR]   htlatex: ./_lists-M-front-matter-WORD 31   Undefined control sequence.
[ERROR]   htlatex: ?    ?    Emergency stop.
[FATAL]   make4ht-lib: Fatal error. Command htlatex returned exit code 1

The line in question (line 57 of sections/0-intro.tex) is the first \cite command to appear in the document. So this leads me back to my earlier hypothesis that it has something to do with biber and/or my .bib file. (My hypothesis about import seems falsified by the fact that make4ht seems to think at least that it is successfully reading sections/0-intro.tex.)

To test it, I reverted my .bib file to how it was before December 14 (when I last successfully compiled the whole thing including citations). No luck -- it still gives the same fatal error.

Did make4ht recently change how it deals with \cite commands or biber, by any chance?

Update 4

Now using the correct -a debug option, my full document's make4ht run provides some details on the \cite issue I mentioned in my "Update 3":

LaTeX Warning: First page is already shipped out, ignoring
               \AtBeginDvi on input line 66.

) (../_outline.tex [1]
! Missing number, treated as zero.
<to be read again>
                   }
l.12 \maketitle

? ! Illegal unit of measure (pt inserted).
<to be read again>
                   }
l.12 \maketitle

? (..//sections-compiled-by-Makefile.tex (..//sections/0-intro.tex
! Missing number, treated as zero.
<to be read again>
                   \begingroup
l.36 \cite[83]{roberts:marcianus:framing}.}

? ! Missing = inserted for \ifnum.
<to be read again>
                   \begingroup
l.36 \cite[83]{roberts:marcianus:framing}.}

? ! Missing number, treated as zero.
<to be read again>
                   \begingroup
l.36 \cite[83]{roberts:marcianus:framing}.}

? ! Argument of \etb@tgl@blx@useauthor has an extra }.
<inserted text>
                \par
l.36 \cite[83]{roberts:marcianus:framing}.}

? Runaway argument?
! Paragraph ended before \etb@tgl@blx@useauthor was complete.
<to be read again>
                   \par
l.36 \cite[83]{roberts:marcianus:framing}.}

? ! Missing number, treated as zero.
<to be read again>
                   \scan_stop:
l.36 \cite[83]{roberts:marcianus:framing}.}

?

Update 5: MWE

I've finally managed to isolate the problem. The package xifthen seems to trip up biblatex so that it no longer works.

main.tex:

%!TEX TS-program = xelatex
%!TEX encoding = UTF-8 Unicode

% Normal:
\documentclass[12pt,letterpaper,oldfontcommands,article]{memoir}
\usepackage{import}

\usepackage[notes,
        alldates=       long,
        backend=        biber,
        bibwarn=        false,
        cmsdate=        both, % reprints: print `origdate` as well as `year`
        compresspages=  true,
        doi=            false,
        eprint=         false,
        giveninits=     true,   % abbreviate author first name(s)
        ibidtracker=    true,
        inheritshorthand,       % feature added for me by D.Fussner
        isbn=           false,
        mincrossrefs =  2,
        numbermonth =   false, % don't print journal issue month even if supplied, when an issue number is also supplied
        useibid,
        shorthandibid,
        strict=         true,
        url=            true,
        usetranslator=  true,
        uniquename= init
    ]{biblatex-chicago}
\addbibresource{test.bib}
    

\usepackage{xifthen}% provides \isempty test


\begin{document}

\cite[83]{roberts:marcianus:framing}

\end{document}

test.bib:

@article{roberts:marcianus:framing,
    author = {Roberts, Alexandre M.},
    journal = {Dumbarton Oaks Papers},
    pages = {69--102},
    read = {1},
    shorttitle = {Framing},
    title = {Framing a Middle Byzantine Alchemical Codex},
    volume = {73},
    year = {2019}
}

myconfig.cfg:

\Preamble{xhtml,ooffice}
\ConfigureOO{Footnote}{
<style:style
    style:name="Footnote"
    style:family="paragraph"
    style:parent-style-name="Standard"
    style:class="extra">\Hnewline
  <style:paragraph-properties
             fo:margin-left="0in"
             fo:margin-right="0in"
             fo:text-indent="0.1in"
              style:auto-text-indent="false"/>
  <style:text-properties fo:font-size="83.3333333333333333333333\%"
      style:font-size-asian="83.3333333333333333333333\%"
      style:font-size-complex="83.3333333333333333333333\%" />
</style:style>\Hnewline
<text:notes-configuration text:note-class="footnote"
    text:citation-style-name="Footnote_20_Symbol"
    text:citation-body-style-name="Footnote_20_anchor"
    style:num-format="1" text:start-value="0"
    text:footnotes-position="page"
    text:start-numbering-at="document" />\Hnewline
<style:style style:name="Footnote_20_Symbol"
style:display-name="Footnote Symbol" style:family="text" >\Hnewline
  <style:text-properties style:text-position="super 58\%" />\Hnewline
</style:style>
<style:style style:name="Footnote_20_anchor"
style:display-name="Footnote anchor" style:family="text">
  <style:text-properties style:text-position="super 58\%" />\Hnewline
</style:style>\Hnewline
}

\ConfigureOO{verse}{\Hnewline
<style:style style:name="verse"
             style:family="paragraph"
             style:parent-style-name="Text-body"
             style:next-style-name="Text-body">
<style:paragraph-properties  fo:margin-left="1.499cm"
             fo:margin-right="1cm"
             fo:margin-top="0cm"
             fo:margin-bottom="0cm"
             fo:text-indent="-0.499cm"
             style:auto-text-indent="false">
   <style:tab-stops/>
</style:paragraph-properties >
</style:style>
\Hnewline}

\def\loopoverdigits#1{\ifx\relax#1\else%
% Unicode block for Arabic numerals starts at U+0660
% the following special command inserts the XML entity
% for the number, which will be converted to Unicode char
% by tex4ht
\special{t4ht@+&{35}x066#1{59}}x%
\expandafter\loopoverdigits\fi}

\def\arabicdigits#1{\NoFonts\loopoverdigits#1\relax\EndNoFonts}
\ifdefined\xeuniuseblock
\xeuniuseblock{Greek}
\xeuniuseblock{Arabic}
\fi
\makeatletter
\ConfigureEnv{arab}{\@rltrue}{\@rlfalse}{}{}
\Configure{ref}{\Link}{\EndLink}{}
\makeatother
\begin{document}
\EndPreamble

When I run the command make4ht -ux -a debug -f odt -c myconfig.cfg main.tex, the following error shows up in the output:

(/usr/local/texlive/2021/texmf-dist/tex/latex/l3packages/xparse/xparse.sty
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/expl3-hooks.4ht)))
(./main.bbl))
! Argument of \etb@tgl@blx@useauthor has an extra }.
<inserted text>
                \par
l.37 \cite[83]{roberts:marcianus:framing}

When I comment out \usepackage{xifthen} in main.tex, the compilation works as expected.

In case the rest of the debug output is useful, here it is:

[INFO]    mkparams: Output dir:
[INFO]    mkparams: Compiler: xelatex --no-pdf
[INFO]    mkparams: Latex options: -jobname=main
[INFO]    mkparams: tex4ht.sty: myconfig.cfg,,charset=utf-8
[INFO]    mkparams: tex4ht:  -cmozhtf -utf8 -.xdv
[INFO]    mkparams: build_file: main.mk4
[INFO]    mkparams: Output format: odt
[STATUS]  make4ht: Conversion started
[STATUS]  make4ht: Input file: main.tex
[INFO]    mkutils: Cannot open config file  main.mk4
[INFO]    make4ht-lib: setting param correct_exit
[INFO]    make4ht-lib: setting param correct_exit
[INFO]    make4ht-lib: setting param correct_exit
[INFO]    make4ht-lib: setting param ext
[INFO]    make4ht-lib: Adding:  ext xdv
[INFO]    htlatex: LaTeX call: xelatex --no-pdf --interaction=errorstopmode -jobname=main   '\makeatletter\def\HCode{\futurelet\HCode\HChar}\def\HChar{\ifx"\HCode\def\HCode"##1"{\Link##1}\expandafter\HCode\else\expandafter\Link\fi}\def\Link#1.a.b.c.{\AddToHook{class/before}{\RequirePackage[#1,html]{tex4ht}}\let\HCode\documentstyle\def\documentstyle{\let\documentstyle\HCode\expandafter\def\csname tex4ht\endcsname{#1,html}\def\HCode####1{\documentstyle[tex4ht,}\@ifnextchar[{\HCode}{\documentstyle[tex4ht]}}}\makeatother\HCode myconfig.cfg,,charset=utf-8,ooffice.a.b.c.\input "\detokenize{main.tex}"'
This is XeTeX, Version 3.141592653-2.6-0.999993 (TeX Live 2021) (preloaded format=xelatex)
 restricted \write18 enabled.
entering extended mode
LaTeX2e <2021-11-15> patch level 1
L3 programming layer <2021-11-22> (./main.tex
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/tex4ht.sty
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/tuenc-xetex-input.4ht
(/usr/local/texlive/2021/texmf-dist/tex/generic/kastrup/binhex.tex)))
(/usr/local/texlive/2021/texmf-dist/tex/latex/memoir/memoir.cls
Document Class: memoir 2021/06/16 v3.7p configurable book, report, article docu
ment class
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/usepackage.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/iftex/iftex.sty)
(/usr/local/texlive/2021/texmf-dist/tex/latex/memoir/mem12.clo)
(/usr/local/texlive/2021/texmf-dist/tex/latex/tools/array.sty)
(/usr/local/texlive/2021/texmf-dist/tex/latex/tools/dcolumn.sty)
(/usr/local/texlive/2021/texmf-dist/tex/latex/tools/delarray.sty)
(/usr/local/texlive/2021/texmf-dist/tex/latex/tools/tabularx.sty)

LaTeX hooks Warning: Generic hook 'package/before/framed' is deprecated.
(hooks)              Use hook 'package/framed/before' instead.

(/usr/local/texlive/2021/texmf-dist/tex/latex/textcase/textcase.sty)

LaTeX hooks Warning: Generic hook 'package/before/float' is deprecated.
(hooks)              Use hook 'package/float/before' instead.

) (/usr/local/texlive/2021/texmf-dist/tex/latex/import/import.sty)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/biblatex-chicago-hooks.4
ht (/usr/local/texlive/2021/texmf-dist/tex/latex/base/ifthen.sty))
(/usr/local/texlive/2021/texmf-dist/tex/latex/biblatex-chicago/biblatex-chicago
.sty (/usr/local/texlive/2021/texmf-dist/tex/latex/etoolbox/etoolbox.sty)
(/usr/local/texlive/2021/texmf-dist/tex/latex/hyperref/nameref.sty
(/usr/local/texlive/2021/texmf-dist/tex/latex/refcount/refcount.sty
(/usr/local/texlive/2021/texmf-dist/tex/generic/ltxcmds/ltxcmds.sty)
(/usr/local/texlive/2021/texmf-dist/tex/generic/infwarerr/infwarerr.sty))
(/usr/local/texlive/2021/texmf-dist/tex/generic/gettitlestring/gettitlestring.s
ty (/usr/local/texlive/2021/texmf-dist/tex/latex/kvoptions/kvoptions.sty
(/usr/local/texlive/2021/texmf-dist/tex/latex/graphics/keyval.sty)
(/usr/local/texlive/2021/texmf-dist/tex/generic/kvsetkeys/kvsetkeys.sty))))
(/usr/local/texlive/2021/texmf-dist/tex/generic/xstring/xstring.sty
(/usr/local/texlive/2021/texmf-dist/tex/generic/xstring/xstring.tex))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/biblatex-hooks.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/latex/biblatex/biblatex.sty
(/usr/local/texlive/2021/texmf-dist/tex/generic/pdftexcmds/pdftexcmds.sty)
(/usr/local/texlive/2021/texmf-dist/tex/latex/logreq/logreq.sty
(/usr/local/texlive/2021/texmf-dist/tex/latex/logreq/logreq.def))
(/usr/local/texlive/2021/texmf-dist/tex/latex/url/url.sty)
(/usr/local/texlive/2021/texmf-dist/tex/latex/biblatex/blx-dm.def)
(/usr/local/texlive/2021/texmf-dist/tex/latex/biblatex/blx-unicode.def)
(/usr/local/texlive/2021/texmf-dist/tex/latex/biblatex/blx-compat.def)
(/usr/local/texlive/2021/texmf-dist/tex/latex/biblatex/biblatex.def)
(/usr/local/texlive/2021/texmf-dist/tex/latex/biblatex-chicago/chicago-notes.bb
x)
(/usr/local/texlive/2021/texmf-dist/tex/latex/biblatex-chicago/chicago-notes.cb
x) (/usr/local/texlive/2021/texmf-dist/tex/latex/biblatex/biblatex.cfg))

Package biblatex Warning: Since you are using the 'memoir' class,
(biblatex)                I'm leaving the formatting of the foot- and/or
(biblatex)                end-note mark and text to you..

) (/usr/local/texlive/2021/texmf-dist/tex/latex/xifthen/xifthen.sty
(/usr/local/texlive/2021/texmf-dist/tex/latex/tools/calc.sty)) (./myconfig.cfg
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/tex4ht.4ht
::::::::::::::::::::::::::::::::::::::::::
 TeX4ht info is available in the log file
::::::::::::::::::::::::::::::::::::::::::
) (/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/tex4ht.sty
l.855 --- TeX4ht warning --- nonprimitive \everypar ---
--- needs --- tex4ht main ---
(./main.tmp) (./main.xref)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/latex.4ht
(/usr/local/texlive/2021/texmf-dist/tex/latex/base/fontenc.sty
(/usr/local/texlive/2021/texmf-dist/tex/latex/lm/t1lmr.fd))
(/usr/local/texlive/2021/texmf-dist/tex/generic/kastrup/binhex.tex)
(/usr/local/texlive/2021/texmf-dist/tex/latex/base/tuenc.def)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/tuenc-xetex.4ht
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/fontmath.4ht
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht [1] [2]
[3] [4] [5] [6] [7] [8] [9] [10] [11] [12] [13] [14] [15] [16] [17] [18]
[19] [20] [21] [22] [23] [24] [25] [26] [27] [28] [29] [30] [31] [32] [33]
[34] [35] [36] [37] [38] [39] [40] [41] [42] [43] [44] [45] [46] [47] [48]
[49] [50] [51] [52] [53])
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/memoir.4ht
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/book.4ht
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/verse.4ht
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/booktabs.4ht
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/array.4ht
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/dcolumn.4ht
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/tabularx.4ht
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ifthen.4ht
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/biblatex-chicago.4ht
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/nameref.4ht
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/biblatex.4ht
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/url.4ht
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/unicode.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/mathml.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/ooffice-mml.4ht))

Package biblatex Warning: Patching footnotes failed.
(biblatex)                Footnote detection will not work.

(/usr/local/texlive/2021/texmf-dist/tex/latex/l3backend/l3backend-xetex.def
(|extractbb --version)) (./main.aux)
(/usr/local/texlive/2021/texmf-dist/tex/latex/base/ts1cmr.fd)
(/usr/local/texlive/2021/texmf-dist/tex/latex/biblatex-chicago/cms-american.lbx
(/usr/local/texlive/2021/texmf-dist/tex/latex/biblatex/lbx/american.lbx
(/usr/local/texlive/2021/texmf-dist/tex/latex/biblatex/lbx/english.lbx))
(/usr/local/texlive/2021/texmf-dist/tex/latex/biblatex/lbx/english.lbx))
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/expl3-hooks.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/latex/l3kernel/expl3.sty)
(/usr/local/texlive/2021/texmf-dist/tex/latex/biblatex/blx-case-expl3.sty
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/expl3-hooks.4ht)
(/usr/local/texlive/2021/texmf-dist/tex/latex/l3packages/xparse/xparse.sty
(/usr/local/texlive/2021/texmf-dist/tex/generic/tex4ht/expl3-hooks.4ht)))
(./main.bbl))
! Argument of \etb@tgl@blx@useauthor has an extra }.
<inserted text>
                \par
l.37 \cite[83]{roberts:marcianus:framing}
8
  • 1
    Could you please add a mwe LaTeX example, and output od make4ht with the '-e debug' option?
    – michal.h21
    Dec 23, 2021 at 7:44
  • Yes, I will do so. I added one just now before realizing that I had made a stupid mistake. Once I manage to reproduce the error with a minimal example, I will post it. Dec 23, 2021 at 22:05
  • I have struggled to reproduce it on a minimal example. But I did notice that without biber, which stopped working as it does from time to time, the compilation works. When I reset biber (with rm -rf `biber --cache`), the fatal error reappeared. So maybe it has something to do with my .bib file. Dec 24, 2021 at 5:10
  • 2
    sorry, it was -a debug. I was on mobile when I suggested it and got it wrong
    – michal.h21
    Dec 24, 2021 at 7:55
  • 1
    we recently fixed lot of things related to BibLaTeX and Hyperref, so it is quite possible that it caused some issues for you.
    – michal.h21
    Dec 24, 2021 at 8:17

1 Answer 1

2

It seems that the error happens because of redefinition of the \TE@repl command in the Xifthen package. The problem is that it clashes with TeX4ht's patch for \ifthenelse, which redefines \begingroup to insert some code and then redefines it back to it's original meaning. We can use the saved original version of \begingroup, \sv:begingroup, instead.

Try this patch file, xifthen.4ht:

\def \TE@repl #1#2{%
  \long \def \@tempc ##1#1##2{%
    \def \@tempb{\@tempc}%
    \sv:begingroup % Thanks MPG
      \toks@ {##2}%
      \edef \@tempa {\the \toks@}% <- UF v1.3
    \expandafter \endgroup
    \ifx \@tempa \@tempb
      \toks@ \expandafter {\the \toks@ ##1}%
      \expandafter \@gobble
    \else
      \toks@ \expandafter {\the \toks@ ##1#2}%
      \expandafter \@tempc
    \fi
    ##2%
  }%
  \toks@ \expandafter {\expandafter}%
  \expandafter \@tempc \the \toks@ #1\@tempc
}
\Hinput{xifthen}
\endinput

It then compiles without errors:

enter image description here

3
  • Thank you! I'm afraid I'm too ignorant to know how to use that patch file, but I look forward to trying it out once it updates on texlive. Dec 25, 2021 at 19:41
  • 1
    @AlexRoberts you can put it to the same directory as your TeX file is. TeX Live should get update soon.
    – michal.h21
    Dec 25, 2021 at 19:44
  • The patch worked -- thanks again! Dec 25, 2021 at 23:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .