When viewing documents in TeXstudio's internal pdf viewer, I am encountering horizontal bars when using the magnify feature.

enter image description here

I am using version 4.1.2, the latest one available as of the writing of this question. I'm not sure what else is relevant information to add here, but I've found this link: Graphics artefacts in integrated PDF viewer, which seems to describe the same problem. Somebody mentioned this was due to a "Qt6 bug", but I frankly do not understand what that is or how to fix it.

On that site, somebody suggested that a way to work around this problem is to change the Windows scaling factor to either 100% or 150% (I have mine on 125% right now). However, I really prefer not to do that because 100% is too small for my eyes on my device, and 150% is too large so that I can't fit many things on screen at once.

Does anybody know of a possible fix to this problem without changing the system-wide Windows scaling? Many thanks in advance.

  • Would be nice to have some minimal code, though.
    – MS-SPO
    Commented Dec 25, 2021 at 15:56
  • @MS-SPO This happens regardless of the document; even an empty document (blank page) triggers this issue.
    – YiFan
    Commented Dec 25, 2021 at 16:03

1 Answer 1


Qt6 is a software package. So there is little you can do, until some people remove this bug.

Using the internal pdf viewer isn't the only option, and often it's not even the best one. Open you .pdf in Adobe reader, or in a webbroswer like Firefox instead. The broswer may be the default program et for .pdf on your computer, while the Adobe reader provides better features for displaying book pages.

  • Thank you for the information. I use the internal pdf viewer as it is more convenient to see the changes updated automatically whenever I recompile, but thanks for the suggestions anyway.
    – YiFan
    Commented Dec 25, 2021 at 16:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .