1

I've been using miktex for months without "unsolvable" problems. However, now, unexpectedly, when I open the MiKTeX Console it appears the following error message:

Invalid or unsupported charset:utf-8.utf-8

and the console does not open. Furthermore, I cannot compile any latex file. When I use texify, or compile with the editor it appears the following error message:

terminate called after throwing an instance of 'boost::locale::conv::invalid_charset_error'

I use an Ubuntu 20.04.3, recently updated. However, I remember that I had compiled a file after the update so it may not be the problem.

Checking errors in the .log files inside .miktex directory I've finded

INFO initexmf.core - forking...

ERROR initexmf.core - Something is wrong with the PATH:

ERROR initexmf.core - /usr/local/sbin:/usr/local/bin:/usr/sb>

So may be there's a wrong path set in some file. How can I know which is the corrupted file?

Thank you for any ideas or comments about this. I'm sorry that I cannot provide more information, these error messages seem to be very cryptic.

New contributor
Guillermo Aparicio-Estrems is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
5
  • 1
    Your question is quite unclear, I have no idea what you mean by "open miktex", but beside this the miktex issue tracker is here: github.com/MiKTeX/miktex/issues Jan 13 at 16:39
  • I mean when opening the MiKTeX Console. Thanks I will check the problem in the tracker. Jan 13 at 16:42
  • Is your locale (i.e., in "Settings->Language and Region") correctly set? You can check what the command locale gives you.
    – Rmano
    Jan 13 at 17:08
  • I suppose yes LANG=en_GB.UTF-8 LANGUAGE=en_GB.UTF-8 LC_CTYPE="en_GB.UTF-8" LC_NUMERIC=es_ES.UTF-8 LC_TIME=es_ES.UTF-8 LC_COLLATE="en_GB.UTF-8" LC_MONETARY=es_ES.UTF-8 LC_MESSAGES="en_GB.UTF-8" LC_PAPER=es_ES.UTF-8 LC_NAME=es_ES.UTF-8 LC_ADDRESS=es_ES.UTF-8 LC_TELEPHONE=es_ES.UTF-8 LC_MEASUREMENT=es_ES.UTF-8 LC_IDENTIFICATION=es_ES.UTF-8 LC_ALL= Jan 13 at 17:21
  • ...seems ok... (you have a similar mix than I have). No further ideas, sorry...
    – Rmano
    Jan 13 at 17:33

Your Answer

Guillermo Aparicio-Estrems is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.