0

I have a very big document (book, over 400 pages, a dozen chapters with a lot of tikz pictures) which used to compile OK. But last TeXlive update, something went wrong. Now the compilation gives me errors on some of my pictures (if not all).

Problem is, I didn't change anything in my class files, and I can't seem to find anything wrong in the code (which used to compile).

I wonder how I could find the problem (which, in my opinion, is some kind of conflict between tikz and another package, maybe tkz-euclide, or something else, which could be solved by putting the packages loading in the right order, or something like that).

I know my question is quite vague, but maybe someone is used to this kind of problem (big document, not possible to provide a minimum example on this site...).

Thanks for any help :-)

Edit : this is the kind of error message I receive :

Chapitre VII.
(./geometrie.mtc7) [177] [178]
Missing character: There is no = in font nullfont!
Missing character: There is no @ in font nullfont!
Missing character: There is no @ in font nullfont!
Runaway argument?
-5:-0.1,samples=200] plot ({fx1(\x )},{fy1(\x )}); \draw     [thick,blue,\ETC.
./courbesaff.tex:209: Paragraph ended before     \pgfmath@local@@functions was complete.
<to be read again> 
                   \par 
l.209 
      
Missing character: There is no L in font nullfont!
Missing character: There is no a in font nullfont!
Missing character: There is no t in font nullfont!
Missing character: There is no a in font nullfont!
Missing character: There is no n in font nullfont!
Missing character: There is no g in font nullfont!
Missing character: There is no e in font nullfont!
Missing character: There is no n in font nullfont!
Missing character: There is no t in font nullfont!
Missing character: There is no e in font nullfont!
Missing character: There is no a in font nullfont!
Missing character: There is no u in font nullfont!
Missing character: There is no p in font nullfont!
Missing character: There is no o in font nullfont!
Missing character: There is no i in font nullfont!
Missing character: There is no n in font nullfont!
Missing character: There is no t in font nullfont!
Missing character: There is no d in font nullfont!
Missing character: There is no e in font nullfont!
Missing character: There is no p in font nullfont!
Missing character: There is no a in font nullfont!
Missing character: There is no r in font nullfont!
Missing character: There is no a in font nullfont!
Missing character: There is no m in font nullfont!
Missing character: There is no  in font nullfont!
Missing character: There is no t in font nullfont!
Missing character: There is no r in font nullfont!
Missing character: There is no e in font nullfont!
Missing character: There is no e in font nullfont!
Missing character: There is no s in font nullfont!
Missing character: There is no t in font nullfont!
Missing character: There is no d in font nullfont!
Missing character: There is no i in font nullfont!
Missing character: There is no r in font nullfont!
Missing character: There is no i in font nullfont!
Missing character: There is no g in font nullfont!
Missing character: There is no  in font nullfont!
Missing character: There is no e in font nullfont!
Missing character: There is no p in font nullfont!
Missing character: There is no a in font nullfont!
Missing character: There is no r in font nullfont!
Missing character: There is no l in font nullfont!
Missing character: There is no e in font nullfont!
Missing character: There is no v in font nullfont!
Missing character: There is no e in font nullfont!
Missing character: There is no c in font nullfont!
Missing character: There is no t in font nullfont!
Missing character: There is no e in font nullfont!
Missing character: There is no u in font nullfont!
Missing character: There is no r in font nullfont!
Missing character: There is no e in font nullfont!
Missing character: There is no t in font nullfont!
Missing character: There is no a in font nullfont!
Missing character: There is no p in font nullfont!
Missing character: There is no o in font nullfont!
Missing character: There is no u in font nullfont!
Missing character: There is no r in font nullfont!
Missing character: There is no  in font nullfont!
Missing character: There is no q in font nullfont!
Missing character: There is no u in font nullfont!
Missing character: There is no a in font nullfont!
Missing character: There is no t in font nullfont!
Missing character: There is no i in font nullfont!
Missing character: There is no o in font nullfont!
Missing character: There is no n in font nullfont!
Missing character: There is no 3 in font nullfont!
Missing character: There is no t in font nullfont!
./courbesaff.tex:213: Missing $ inserted.
<inserted text> 
                $
l.213       3t^
               2(x-a t^2)-2t(y-a t^3)=0\iff 3tx-2y-a t^3=0
./courbesaff.tex:214: Missing $ inserted.
<inserted text> 
                $
l.214     \end{equation*}
    

The "faulty code :

\begin{figure}[htbp]
  \centering
  \begin{tikzpicture}[declare function = {
      fx1(\t) = 2/\t;
      fy1(\t) = 2*\t*\t;
      fx2(\t) = 3*\t/(\t*\t+pow(4,-1/3));
      fy2(\t) = 6*pow(4,-2/3)/(\t*\t+pow(4,-1/3));
    }]
    \tikzdrawaxislabelclip{-5.2}{5.2}{-0.5}{7.2};
    \draw[thin] (1,-0.05) node[below]{$\spt1$} -- (1,0.05)
    (-0.05,1) node[left]{$\spt1$} -- (0.05,1) (0,0) node[below
    left]{$\spt O$} (0-0.05,{3*pow(4,-1/3)}) node[left]{$\spt A$} --
    (0+0.05,{3*pow(4,-1/3)});
    \draw[thick,blue,domain=-5:-0.1,samples=200] plot
    ({fx1(\x)},{fy1(\x)});
    \draw[thick,blue,domain=0.1:5,samples=200] plot
    ({fx1(\x)},{fy1(\x)});
    \draw[thick,violet,domain=-100:-10,samples=200] plot
    ({fx2(\x)},{fy2(\x)}); 
    \draw[thick,violet,domain=-10:-1,samples=200] plot
    ({fx2(\x)},{fy2(\x)}); 
    \draw[thick,violet,domain=-1:1,samples=200] plot
    ({fx2(\x)},{fy2(\x)}); 
    \draw[thick,violet,domain=1:10,samples=200] plot
    ({fx2(\x)},{fy2(\x)}); 
    \draw[thick,violet,domain=10:100,samples=200] plot
    ({fx2(\x)},{fy2(\x)}); 
    \draw[thin,red,domain=-5.2:5.2] plot (\x,6-2*\x);
    \draw[thin,red,domain=-5.2:5.2] plot (\x,{\x/2+6*pow(4,-2/3)});
  \end{tikzpicture}
  % \includegraphics[scale=0.75]{courbesaff.101}
  \caption{Orthoptique de l'arc paramétré $x=\frac{a}{t}$, $y=at^2$}
\end{figure}
\item \fbox{$f(t)=(a t^2,a t^3)$}

La tangente au point de paramètre $t$ est dirigée par le vecteur
$(2,3t)$ et a pour équation
\begin{equation*}
  3t^2(x-a t^2)-2t(y-a t^3)=0\iff 3tx-2y-a t^3=0
\end{equation*}

That used to compile fine. I'm getting a lot of those "Missing character in font nullfont" these days, wonder why, too.

Another error at another picture : I draw some Euler line of a triangle. I define all my points, and on the first line drawing something :

\tkzDrawLine[add= 1 and 1](A,B)

I get this error message :

./enveloppes.tex:143: Package tikz Error: + or - expected.

See the tikz package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                  
l.143       \tkzDrawLine[add= 1 and 1](A,B)
                                       

./enveloppes.tex:143: Package tikz Error: Giving up on this path.     Did you forget a semicolon?.

If someone have an idea (I know, it may be hopeless...), I would be so glad :-)

5
  • 2
    show the first error, copied from the log file, marked in your question as a code block so line endings are preserved. Jan 15, 2022 at 16:54
  • It's possible that tkz-euclide is the culprit. There have been significant changes in the latest version. My email is in my package documentation if you want me to analyze your document. Otherwise have you seen : tex.stackexchange.com/questions/629309/… Jan 15, 2022 at 17:14
  • @DavidCarlisle : I edited my post. Jan 16, 2022 at 0:08
  • @AlainMatthes : thanks Alain. I saw the message about removing cm units, I think I use it only with basic tikz, when I want to enlarge a segment (shorten <= ou >=...). The only unit I added in my class file is a "pt" to get the correct size of a circle diameter, and don't think it has something to do with tkz-euclide... But I may be wrong about that, my classes have grown huge these days :-( Jan 16, 2022 at 0:11
  • You need a complete example with the preamble. There we can't know because your code doesn't compile Jan 16, 2022 at 6:04

1 Answer 1

0

I finally found the problem : it was an error between tikz and babel. Adding the library babel to the tikz libraries solved it.

Sorry for the noise.

Not the answer you're looking for? Browse other questions tagged .