I'm using Xelatex with biblatex and the biber.exe backend:

\setmainfont{Sabon LT}
\setsansfont{Syntax LT}
\setmonofont{Courier New} 
\usepackage[bibstyle=nature, citestyle=numeric-comp, sorting=none,backend=biber]{biblatex}%this style compresses the numbering 

some text
some unicode text áâäæèê\\
some unicode text: Parenicovà          áâäæèê with an unicode reference \autocite{Parenicova2000a}\\
unicode reference two Jørgensen \autocite{Joergensen2009}\\
Reference without unicode \autocite{Wu2004}

Unicode characters are displayed correctly in the text body, however in the reference list the unicode characters are omitted (see attached image)

This is not a problem related to my .bib library, I encod my library in UTF-8 (UTF-16 tested too, no difference) when I use normal pdflatex and biblatex characters are displayed normally. I think the error is related to biber.exe in combination with my Windows Vista, the following error is displayed when I run biber.exe on the .bcf file manually:

F:\LaTeX\xetex_testing>biber.exe testB.bcf
Could not find or check module 'IPC::Run' [THIS MAY BE A PROBLEM!] at IPC/Cmd.pm
 line 125
Already tried to use 'IO::Select', which was unsuccessful [THIS MAY BE A PROBLEM
!] at IPC/Cmd.pm line 154
INFO - Logfile is 'testB.blg'
INFO - Found 'testB.bcf'
INFO - Reading testB.bcf
WARN - Warning: You are using biblatex version 1.0 :
biber is more likely to work with version 0.9e.
INFO - Found 3 citekeys in bib section 0
INFO - Processing bib section 0
INFO - Found 'cluster.bib'
INFO - Processing file 'cluster.bib' for section 0
INFO - Decoding LaTeX character macros into UTF-8
Unicode::Collate: Can't locate Unicode\Collate\allkeys.txt in @INC (@INC contain
s: C:\Users\Tim\AppData\Local\Temp\par-Tim\cache-ef9b516290b60f6dc5518a4b5db3004
32676b908\inc\lib C:\Users\Tim\AppData\Local\Temp\par-Tim\cache-ef9b516290b60f6d
c5518a4b5db300432676b908\inc CODE(0x2cc0b14) CODE(0x2cc0e14)) at Biber.pm line 1

So is this specifically a biber related error, or am I doing something wrong? All help is much appreciated.

alt text


Althought my bib file was showing all unicode characters properly in my reference program (jabref) the encoding of the bib file seemed to be the problem (apparently jabref saved it as Cp1252?) After converting the bib file with an external text editor to UTF8, Everything works perfectly!

  • 1
    Could you add somewhere your bibliography database to the example, either as a separate piece of code or using the filecontents environment.
    – Joseph Wright
    Dec 1, 2010 at 11:56
  • Also, can you tell us about your biber version. For example, did you build it yourself, download it from the biber homepage, get it using TLContrib or by some other route?
    – Joseph Wright
    Dec 1, 2010 at 12:12
  • I was running version 0.5.7, downloaded from sourceforge. Now i'm using v0.6 but still the problem is not solved. How can I add my .bib file to my post? I cannot see any fileattachement links.
    – Timtico
    Dec 1, 2010 at 12:43
  • You can change the encoding of a bib file in JabRef via “File -> Database properties -> Database encoding”.
    – domwass
    Dec 1, 2010 at 14:12

1 Answer 1


I tested a complete example with unicode characters using the XeLaTeX/biber combo, and it works fine. Your log shows that you're using an old biber version, and this may be the cause of your problem (changes to the Unicode sorting mechanism were added to biber lately). Try upgrading to biber v0.6.

EDIT: Here's the example that works for me:


\setmainfont{Palatino Linotype}



  author = {Jørgensen, J.},
  year = {2001},
  title = {Alpha áâäæèê},





  • Upgraded from 0.5.7 to v0.6 and there is no difference still noto working. How can I upload my .bib file here?
    – Timtico
    Dec 1, 2010 at 12:39
  • btw. I no longer get any errorcodes when running biber on the .bcf file however.
    – Timtico
    Dec 1, 2010 at 12:40
  • Your example works fine for me... So I suspect that it has something to do with the way my bib is encoded. I set jabref to store the bib files as utf8 but perhaps it didnt do that properly: % This file was created with JabRef 2.6. % Encoding: Cp1252
    – Timtico
    Dec 1, 2010 at 13:47
  • YES! it was solved, I opened my .bib file in my text editor and explicitly converted it to UTF-8. Now my references are showing as they should be! Thanks everyone for the help!
    – Timtico
    Dec 1, 2010 at 13:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .