3

Under macOS Big Sur using LaTeX the following document does not compile:

\documentclass[]{article}

\usepackage{pigpen}

\begin{document}

{\pigpenfont L}

\end{document}

It produces the following console output:

This is pdfTeX, Version 3.141592653-2.6-1.40.23 (TeX Live 2022/dev) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
(./test.tex
LaTeX2e <2021-11-15> patch level 1
L3 programming layer <2022-01-12>
(/usr/local/texlive/2021/texmf-dist/tex/latex/base/article.cls
Document Class: article 2021/10/04 v1.4n Standard LaTeX document class
(/usr/local/texlive/2021/texmf-dist/tex/latex/base/size10.clo))
(/usr/local/texlive/2021/texmf-dist/tex/latex/pigpen/pigpen.sty
(/usr/local/texlive/2021/texmf-dist/tex/latex/pigpen/pigpen.tex))
(/usr/local/texlive/2021/texmf-dist/tex/latex/l3backend/l3backend-pdftex.def)
(./test.aux) [1{/usr/local/texlive/2021/texmf-var/fonts/map/pdftex/updmap/pdfte
x.map}] (./test.aux) )</usr/local/texlive/2021/texmf-dist/fonts/type1/public/am
sfonts/cm/cmr10.pfb><</usr/local/texlive/2021/texmf-dist/fonts/type1/public/pig
pen/pigpen.pfa>>
!pdfTeX error: /Library/TeX/texbin/pdflatex: builtin glyph names is empty
 ==> Fatal error occurred, no output PDF file produced!

Does anybody know where the problem could be? It worked last year...

Thanks a lot.

2

1 Answer 1

5

2024 update an updated map file has been uploaded to ctan so the fix below will not be needed.


From texlive 2021 onwards LaTeX by default includes a glyph to Unicode mapping. This font apparently fails in that setting. You can disable this mapping:

\documentclass[]{article}

\usepackage{pigpen}
\pdfgentounicode=0
\begin{document}

{\pigpenfont L}



\end{document}

enter image description here

You can just disable this for pigpen but leave the unicode mappings for other defaults by over-riding the pigpen map file

\documentclass[]{article}

\usepackage{pigpen}
% \pdfgentounicode=0
\pdfmapline{=pigpen <pigpen.pfa}
\begin{document}

{\pigpenfont L}



\end{document}
4
  • Thanks a lot, it works!
    – pro-kswe
    Jan 19, 2022 at 16:54
  • Is there a possibility to switch that off globally? In other words, to revert pdfTeX to its old behaviour? May 7, 2022 at 6:34
  • 1
    you could use a non standard pdftex.ini that set that @TorstenBronger but if you are getting errors that need that might be best to raise a issue with pdftex maitainers and see if pdftex can more gracefully recover May 7, 2022 at 7:58
  • @TorstenBronger see also tex.stackexchange.com/a/634975/2388 May 7, 2022 at 8:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .