1

I would like three things:

  1. uppercase title and label,
  2. not bold, and
  3. centered.

I put the respective commands in the {label} section of the \titleformat command but nothing is happening. Both label and title appear to the left, bold, and not uppercase.

I just spent two hours reading the documentation for Titlesec and I must confess I did not get all of it. Please, help.

\documentclass[letterpaper,12pt]{book}
\usepackage[hmargin={1in},vmargin=1in]{geometry}

\usepackage{fancyhdr}
\pagestyle{fancy}
\fancyhead{}
\fancyfoot[L,R]{}
\fancyfoot[C]{\thepage}
\renewcommand{\headrulewidth}{0pt}
\renewcommand{\footrulewidth}{0pt}

\usepackage{titlesec}
\titleformat{\chapter}[display]{\normalfont\Large\rmfamily}{\filcenter\MakeUppercase{\chaptertitlename} \thechapter}{1pc}{}


\usepackage{setspace}
\AtBeginDocument{\doublespacing}
\usepackage{stackengine}

\usepackage{polyglossia}
\usepackage{fontspec}

\setmainlanguage[variant=us]{english}
\setotherlanguage{hebrew}
\setotherlanguage[variant=ancient]{greek}

\setmainfont{Times New Roman}
\newfontfamily\greekfont[Script=Greek, Scale=MatchUppercase, Ligatures=TeX]{SBL BibLit}
\newfontfamily\hebrewfont[Script=Hebrew,Contextuals=Alternate,Ligatures=Required]{SBL BibLit}

\begin{document}
\chapter{Palaeographical Profile}

\end{document}
1
  • 1
    I have solved this one for you. You can see if when I send you my sample.
    – Paul
    Jan 21, 2022 at 14:18

1 Answer 1

2

You need to put \filcenter in a different position and also to add \MakeUppercase for the chapter title.

Here's just the necessary code (with just titlesec for showing the issues)

\documentclass[letterpaper,12pt]{book}
\usepackage{titlesec}

\titleformat{\chapter}[display]
  {\normalfont\Large\rmfamily\filcenter}
  {\MakeUppercase{\chaptertitlename} \thechapter}
  {1pc}
  {\MakeUppercase}

\begin{document}

\chapter{Palaeographical Profile}

\end{document}

enter image description here

Here's an edited version of your preamble with less clutter: packages first and then settings.

\documentclass[letterpaper,12pt]{book}
\usepackage[hmargin={1in},vmargin=1in]{geometry}
\usepackage{setspace}
\usepackage{fancyhdr}
\usepackage{titlesec}
\usepackage{stackengine}
\usepackage{polyglossia}
\usepackage{fontspec}

\setmainlanguage[variant=us]{english}
\setotherlanguage{hebrew}
\setotherlanguage[variant=ancient]{greek}

\setmainfont{Times New Roman}
\newfontfamily\greekfont{SBL BibLit}[
  Script=Greek,
  Scale=MatchUppercase,
  Ligatures=TeX
]
\newfontfamily\hebrewfont{SBL BibLit}[
  Script=Hebrew,
  Contextuals=Alternate,
  Ligatures=Required
]

\pagestyle{fancy}
\fancyhf{}
\fancyfoot[C]{\thepage}
\renewcommand{\headrulewidth}{0pt}
%\renewcommand{\footrulewidth}{0pt}

\titleformat{\chapter}[display]
  {\normalfont\Large\rmfamily\filcenter}
  {\MakeUppercase{\chaptertitlename} \thechapter}
  {1pc}
  {\MakeUppercase}

\doublespacing

\begin{document}

\chapter{Palaeographical Profile}

\end{document}
4
  • Thank you. The documentation wasn't too clear regarding the position of the commands (or I completely missed it). May I ask why you repeated the \MakeUppercase command at the end? Isn't that the {before code} slot?
    – Rob28
    Jan 20, 2022 at 22:19
  • 1
    @Rob28 In the last mandatory argument to \titleformat the last item can be a one argument macro, which is passed the title. In this case I use \MakeUppercase.
    – egreg
    Jan 20, 2022 at 22:21
  • why did you remove the \AtBeginDocument command for \doublespacing? Redundant?
    – Rob28
    Jan 21, 2022 at 13:25
  • @Rob28 Yes, it's not needed.
    – egreg
    Jan 21, 2022 at 14:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .