1

I try to use tex4ebook with MikTex and TeXnicCenter, but it always leads to a fatal error.

My simple MWE:

\documentclass{article}
\begin{document}
Text
\end{document}

I tried a lot of different commands to be passed to the Compiler, e.g.

-c config.cfg -f epub3 "%wm"

but it does not work. The output/error is like that:

tex4ebook> [WARNING] tocid: char-def module not found
tex4ebook> [WARNING] tocid: cannot fix section id's
tex4ebook> This is pdfTeX, Version 3.141592653-2.6-1.40.23 (MiKTeX 21.10)
tex4ebook> entering extended mode
tex4ebook> [FATAL] make4ht-lib: Fatal error. Command tex4ht returned exit code 1

Which commands have to be passed to the Compiler in TeXnicCenter to make tex4ebook running?

4
  • try to add the -a debug option to see full error log, and post it here. TeX4ebook hides log by default and it can contain some information why it fails on your machine.
    – michal.h21
    Jan 21 at 23:13
  • @michal.h21: Thanks for the hint - I had to copy the bibtex.exe and makeindex.exe from miktex/bin/x64 one folder up to miktex/bin - now it works :-)
    – Jack
    Jan 22 at 10:26
  • Ah, I wasn't suspecting bibtex or makeindex to be culprits, but I am glad that you found the fix :)
    – michal.h21
    Jan 22 at 11:11
  • Thanks a lot - I would not have found it without the full error log :)
    – Jack
    Jan 22 at 11:16

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.