0

I can't figure out how to get the sections and subsections to show up in the Table of Contents (TOC) in the tufte-book class. This template/PDF states on page 28 that the option [notoc] forces the class to revert back to a standard LaTeX TOC:

https://v1.overleaf.com/latex/templates/book-design-inspired-by-edward-tufte/gcfbtdjfqdjh.pdf

Yet, I have tried that on both MiKTeK and Overleaf and it is just not the case. Am I missing something?

1
  • Welcome to TeX.SX! Commented Jan 25, 2022 at 14:12

2 Answers 2

4

Increase the value of tocdepth and secnumdepth. The tocdepth value determines to which level the sectioning commands are printed in the ToC (they are always included in the .toc file but ignored otherwise). The secnumdepth value determines up to what level the sectioning titles are numbered. They are LaTeX counters and you can set them using \setcounter.

From How to show sections and subsections in TOC

Using

% !TeX TS-program = pdflatex

\documentclass{tufte-book}
\setcounter{tocdepth}{2}
\setcounter{secnumdepth}{2}

....

will output (for sample-book.tex)

a

The notoc option suppresses the Tufte-style of the table of contents.

Now using with the same file

% !TeX TS-program = pdflatex

\documentclass[notoc]{tufte-book}
\setcounter{tocdepth}{2}
\setcounter{secnumdepth}{2}

....

the result is

c

1
0

The value of the tocdepth counter decides which levels of outline are output. It is set to 0 in the tufte-book.cls class file. Change the value of the counter in your preamble to get the output you want. This seems to be independent of whether you set the notoc option or not.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .