0

I'm running on macOS Big Sur 11.4. Hopefully, someone can help me.

Recently, I wasn't able to compile R packages properly, so it was suggested to me to remove all file from /usr/local via

sudo rm -rf /usr/local/*

Now my packages compile as needed, but for some odd reason, LaTeX pdfs no longer compile.

When I navigate over to /usr/local/bin and look at what files are there, I see

R           makeinfo        texi2any
Rscript         pdftexi2dvi     texi2dvi
gfortran        pod2texi        texi2pdf
info            sqlite3_analyzer    texindex
install-info        tclsh8.6        wish8.6

but I'm not sure if something may have been erased.

I'm no computer wizard, so any help in fixing the issue is greatly appreciated.

EDIT

When I do a Quick Build, the pdf screen does not appear and the pdf is not generated. I just get a number of warnings pertaining to missing fonts and under/overfulls, which were not there prior to the problem occurring. The square boxes in the blue text occurred when I updated to macOS Big Sur long before the current problem happened

Should I just uninstall and reinstall LaTeX?

enter image description here

EDIT:

I am using TeXmaker with pdfTeX, Version 3.14159265-2.6-1.40.17.

Unfortunately, this is all I am able to gather because when I updated to macOS Big Sur this summer, it somehow corrupted my TeX messages (but everything else still worked up until now).

18
  • 4
    You were advised to do rm -fr /usr/local/? That's really bad advice.
    – egreg
    Jan 27, 2022 at 18:42
  • you really should not follow an advice telling you to erase everything in a folder. Jan 27, 2022 at 18:42
  • Can I restore /usr/local? Jan 27, 2022 at 18:44
  • you can only restore it if you backed it up Jan 27, 2022 at 18:59
  • but if you are generating the warnings you show in the summary image, you must have tex installed somewhere Jan 27, 2022 at 19:00

1 Answer 1

0

The issue has been solved.

I simply uninstalled LaTeX by moving the TeX folders in /Applications and /Library to the trash and then installed the latest version of MacTeX (my previous install was from 2017) and TeXmaker (the LaTex editor I use).

I then simply had to declare

\UseRawInputEncoding

in the preamble of my documents.

Hopefully my experience can help someone in the future (and to NOT do rm -fr /usr/local/ (although to my knowledge, only R and LaTeX files in /usr/local),

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .