0

I'm using MiKTeX 2.09 (and TeXstudio) on windows 7. When I choose the glossary command in TeXstudio to make the glossary, I run into this error:

Process started: makeglossaries.exe "HSFSS"

Sorry, but makeglossaries.exe did not succeed for the following reason: MiKTeX could not find the script engine 'perl' which is required to execute 'makeglossaries'. Remedy: Make sure 'perl' is installed on your system. The log file hopefully contains the information to get MiKTeX going again: C:\Users\Love\AppData\Local\MiKTeX\2.9\miktex\log\makeglossaries.log For more information, visit: https://miktex.org/kb/fix-script-engine-not-found

Process exited with error(s)

I tried to run this command on the system prompt:

powershell -Command "& $([scriptblock]::Create((New-Object Net.WebClient).DownloadString('https://platform.activestate.com/dl/cli/AS701/install-latest.ps1'))) -c'state activate --default youarelove-gmail-com/Perl-5.34.0-Windows'"

but received this error:

Microsoft Windows [Version 6.1.7601] Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>where perl.exe

INFO: Could not find files for the given pattern(s).

C:\Windows\system32>powershell -Command "& $([scriptblock]::Create((New-Object N et.WebClient).DownloadString('https://platform.activestate.com/dl/cli/AS701/inst all-latest.ps1'))) -c'state activate --default youarelove-gmail-com/Perl-5.34.0- Windows'" The string starting: At line:1 char:207

  • & $([scriptblock]::Create((New-Object Net.WebClient).DownloadString('https:// platform.activestate.com/dl/cli/AS701/install-latest.ps1'))) -c'state activate --default youarelove-gmail-com/Perl-5.34.0-Windows <<<< ' is missing the terminator: '. At line:1 char:208
  • & $([scriptblock]::Create((New-Object Net.WebClient).DownloadString('https:// platform.activestate.com/dl/cli/AS701/install-latest.ps1'))) -c'state activate --default youarelove-gmail-com/Perl-5.34.0-Windows' <<<<
    • CategoryInfo : ParserError: (:String) [], ParentContainsErrorRe cordException
    • FullyQualifiedErrorId : TerminatorExpectedAtEndOfString

C:\Windows\system32>

Not sure where to go from here. Any advice is much appreciated!

2
  • 1
    Install https://strawberryperl.com/ on Windows
    – Mafsi
    Jan 30, 2022 at 6:29
  • 1
    @mafsi Issue resolved. Thank you!
    – Steven
    Jan 30, 2022 at 6:44

1 Answer 1

2

Installing https://strawberryperl.com/ resolved my issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .