0

I have found I am unable to use an equals sign in the titles of tcolorboxes.

\begin{tcolorbox}[title=foo\=bar]
\end{tcolorbox}

enter image description here

Using a normal equals sign messes with the parameter syntax, and using \={} causes it to be a high horizontal line over any subsequent character.

Is there any way to make it show an equals sign correctly?

3
  • 4
    \= is a macron accent command, use title={foo=bar} to hide an = Feb 9, 2022 at 19:42
  • @DavidCarlisle That shows the equals sign correctly but it also a does weird thing with the spacing between words. title={nmap -sV --script=vulscan/vulscan.nse --script-args vulscandb=cve.csv --disable-arp-ping 192.168.1.0/24} is the actual title I am using. Feb 9, 2022 at 19:51
  • that would be a different question and the spacing depends on fonts and page size and other stuff you haven't shown (it is always best to provide a complete small test document in the question) but the issues ar completely separate, presumably you get somilar space issue if you had used a simpler character with say - instead of = so theanswer to yiour parsing question is to use {..} but you can ask a new question about the typesetting if you provide an example Feb 9, 2022 at 19:53

1 Answer 1

1

\= is a macron accent command. In common with most other commands taking a key-value list, you can use braces to hide commas or equals signs in a value, so

 title={foo=bar} 

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .