1

There was a similar thread a year ago that led nowhere. I installed miktex as administrator (win10, x64) from the texcol2021-DVD on a computer not connected to the internet. When I try to install an additional package I get the strange message "the configuration file is not signed" using "Drive:\protext\MiKTeX\tm\packages" as repository. I could copy the sty-file into tfmlocal. That worked but is unsatisfactory. Any helpful comments?

E.g. It would be helpful to understand, what the error means and how I can resolve the problem. The full error message consists of two parts:

  1. A MiKTeX configuration file could not be loaded.
  2. file="C:\Program Files\MiKTeX 2.9\miktex/config\mpm.ini", line="35324", error="the configuration file is not signed"

35324 is the last line of mpm.ini. The DVD installs MiKTeX 21.2.

I tried to write the following as a comment but couldn't get it formatted. Therefore I append it to my original post: The mpm.ini in question has the following header:

;;; DO NOT EDIT THIS FILE DIRECTLY

;;; Modified Basic MiKTeX Package Set, prepared for TeX Collection DVD 2020
;;; Klaus Hoeppner, DANTE e.V., 2021-02-25

but no signature. On a different computer mpm.ini has a signature at the bottom:

;;;;This configuration file is signed by a MiKTeX maintainer. The signature follows.
;;;;-----BEGIN MIKTEX SIGNATURE-----
;;;; signature/miktex: Fe6uJKFvJGByWg4OgaAebZ8Xxim1 [rest of line omitted]
;;;;-----END MIKTEX SIGNATURE-----

Who creates the signature and when?

1
  • Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Feb 14 at 5:27

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.