i'm new, so I hope to do everything correctly :D

My question is fairly simple:

I've the natbib package loaded in a document, and some bibliography entries have no author. Those entries are put at the beginning of the bibliography, creating a somehow bad effect on the reader (at a first glance to the bib first page is not possible to tell the order in which the entries are presented).

Question is: how do I change it?

What I've tried so far:

  • the "key" field: it doesn't work. The following image presents what happens if I set "key={zzzzz}" for a bibliography entry with no author:

enter image description here

A working example:






Blah Blah \citet{aida}




  year = {2011-2012},
  title = {Aida database},
  organization = {Bureau Van Dijk},
  url = {http://aida.bvdep.com},
  key = {zzzzzz}


  • And where should they go instead? At the end of the document? (Guessing from the 'zzzzzz'....)
    – jon
    Commented Jul 15, 2012 at 22:37
  • It seems you forgot to insert the image, showing the problem with your approach. Also please make a real MWE, i.e. remove all irrelevant classe.
    – bodo
    Commented Jul 16, 2012 at 5:42
  • Yes, I would like to put them all at the end of the bibliography. I cannot insert the image (not enough reputation, if I understood correctly)... Commented Jul 16, 2012 at 11:48

2 Answers 2


The solution I propose is to use the cite package instead of natbib.

I encountered the same problem as you when citing websites. The only reason I used natbib was to numerically sort multiple citations ([1,3,4] instead of [3,4,1]), but the cite package also sorts citations.

  • First of all thanks for the answer. However i didn't mention in the question that I pretty much have to use the (author;year) citation system, does the cite package allow it? Commented Jul 16, 2012 at 14:16
  • I'd say you can achieve that by making your own bibliography style. But that may be a bit cumbersome. Commented Jul 16, 2012 at 14:31
  • Yep I think so... I'll give it a try! Commented Jul 16, 2012 at 16:40

If you must use natbib and plainnat, consider the following two options.

  1. If you don't like having the key field displayed at the beginning of your entry (or at all) or have to customize each bibliographic entry to use key instead of organization, consider the answer to a nearly duplicate post here on TeX Stack Exchange describing how to customize your BST file.

  2. The \noopsort capability may be helpful to you. There's discussion on it here on TeX Stack Exchange involving a situation in which the user who initially posted the question wants to have all of the author-less bibliographic entries at the end.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .