3

After the last update of footmisc, reledmac and footmisc are incompatible. This mwe shows the basis of my environment.

\documentclass{memoir} 
\usepackage{footmisc} 
\usepackage{reledmac}     
\begin{document} 
\beginnumbering 
\pstart 
\edtext{Hello}{\Afootnote{world.}} 
\pend 
\endnumbering 
\end{document}
16
  • 2
    You shouldn't use local fonts when reporting such problems. Commented Feb 17, 2022 at 12:46
  • I inserted a very common font in fact the font I use is Brill. I didn't know how to go about showing the code I use. Commented Feb 17, 2022 at 12:57
  • 2
    You don't need any font setting at all to produce the problem, polyglossia isn't needed either. Commented Feb 17, 2022 at 13:00
  • 1
    @Paolo: great. Could you please add that info to the question then? And feel free to use my simpler MWE in the question, as it displays the same problem.
    – marquinho
    Commented Feb 17, 2022 at 14:09
  • 1
    I'm (memoir maintainer here), why are you loading footmisc in the first place? What exactly do you need from footmisc?
    – daleif
    Commented Feb 17, 2022 at 15:55

2 Answers 2

5

As far as I can see the problem always lurked in the redefinitions memoir does to the internal output routine commands of LaTeX. You can also produce it, for example, with your example and the old footmisc from 2011, if you add the option "bottom" to footmisc.

The problem only became more appearent new due to the new footmisc being based on updates to the internal LaTeX output routine commands. They are currently only in footmisc, but will eventually make it to the kernel itself.

For the moment you can combine memoir and footmisc, by using the old footmisc release, i.e., by using

\usepackage{footmisc}[=v5]

That is obviously not a permanent solution because it takes footmisc back to its 2011 version (including the bugs it had then), but it should get you the same behavior as before for now.

Midterm when the new output routine ends up in the LaTeX format, memoir needs to change its behavior and instead if flately overwriting parts, use the (then) available interfaces to implements its version.

By the way: it is not reledmac + footmisc that are incompatible. Your example works perfectly well if you use a different documentclass, say article or book with your example. So please update the title of this question.

3

Here is a possible workaround

\documentclass{memoir}
\usepackage{footmisc}
\usepackage{reledmac}
\makeatletter
\AtBeginDocument{
  \appto\@makecol@appendblocks{%
    \m@mdoextrafeet%
    \m@mopsidefoot%
    \m@mopsidebar}%
}
\makeatother
\begin{document}
\beginnumbering
\pstart
\edtext{Hello}{\Afootnote{world.}}
\pend
\endnumbering
\end{document}

it is probably mostly \appto\@makecol@appendblocks{\m@mdoextrafeet} that is missing when footmisc overwrites \@makecol

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .