1

I'm using vscode with the latex-workshop extension, and the compilation sometimes hangs when compiling tikz graphics.

The FAQ recommends in this case:

When builds result in an infinite loop with TikZ or other advanced packages, please replace -interaction=nonstopmode with -halt-on-error in your recipe.

But how do I do this? The recipes are not in settings.json but in ~/.vscode/extensions/james-yu.latex-workshop-8.23.0/package.json, and I don't think I'm supposed to edit that directly?

What should I put in settings.json to change say the latexmk tool (which is called by the latexmk recipe if I understand correctly, see here) to --halt-on-error?

1 Answer 1

1

The setting can be modified in the settings.json file at

latex-workshop.latex.magic.args

or from VSCode settings interface as can be seen from the picture below. enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .