1

I would like the citation for \citet{sample} to appear as:

Jonas & Brothers (2022) instead of Jonas and Brothers (2022).

How would you change and to & in the case of two-author citations?

4
  • Please tell us which bibliography style you employ.
    – Mico
    Mar 2, 2022 at 3:17
  • @Mico, thanks for the reply. I use \bibliographystyle{apalike}. I am sorry for not posting the entire code, but I think I am using natbib package. Mar 2, 2022 at 3:22
  • Thanks for answering my question. One more question (sorry): Do you want to employ & as the conjunction both in the citation call-out and in the formatted bibliographic entry, or just in the citation call-out?
    – Mico
    Mar 2, 2022 at 3:40
  • 1
    @Mico, thanks for the specific question! I didn't even think about this, but it is important. Basically, in the actual paper, I want only two-author citations have "&" and any citation with more than two people with "et al." citation. In reference, I would like to have any multiple author (2 or more) citations to have "&". I hope I explained this correctly :( Mar 2, 2022 at 3:44

1 Answer 1

1

Since you employ the apalike bibliography style -- BTW, apalike dates back to 1988 [!] and does not embed current APA formatting guidelines -- I suggest you proceed as follows:

  • Find the file apalike.bst in your TeX distribution. Make a copy of this file and call the copy, say, apalike-ampersand.bst. (Do not edit an original file of the TeX distribution directly.)

  • Open the file apalike-ampersand.bst in an editor. The program you use to edit your tex files will do fine.

  • Locate both instances of the hard-coded string " and " in the bst file. (In my copy of the file, they occur on lines 225 and 851.) The first instance affects the formatting of multiple-author bibliographic entries, and the second affects the formatting of two-author citation call-outs.

  • Change both instances to "~\& ".

  • Save the file apalike-ampersand.bst either in the directory that contains your main tex file or in a directory that's searched by BibTeX. If you choose the second option, be sure to update the filename database of your TeX distribution in a suitable manner. (If you have no idea that the preceding sentence means, I suggest you employ the first option.)

  • In your main tex file, change the instruction \bibliographystyle{apalike} to \bibliographystyle{apalike-ampersand} and perform a full recompilation run -- LaTeX, BibTeX, and LaTeX twice more -- to propagate all changes.

Happy BibTeXing!


Here's a minimal example and associated screen shot that put these ideas to work.

enter image description here

\documentclass{article} % or some other suitable document class
% Create a sample bib file on the fly:
\begin{filecontents}[overwrite]{mybib.bib}
@misc{jb:2022, author={Xavier Jonas and Yves Brothers}, title={Thoughts}, year=2022}
@misc{abc:3001, author={Anne Author and Brenda Branford and Chiara Cavendish}, title = {Thoughts}, year=3001}
\end{filecontents}

\usepackage[authoryear,round]{natbib}
\bibliographystyle{apalike-ampersand}

\begin{document}
\citet{jb:2022}, \citet{abc:3001}
\bibliography{mybib}
\end{document}
3
  • Mico, thank you so much! I am going to try that very soon! I just have one additional question. Do you know if the title in the reference section (bibliography) are capitalized? For example, I would like to have the company name "The Magic Behind Tiffay & Co" appear as it is in the paper's title, but it appears like "The magic behind tiffay & co." Mar 2, 2022 at 5:13
  • @FrankSwanton - You're most welcome. Regarding your follow-up question, about why the apalike style tells BibTeX to lowercase all letters but the very first in the title field: Please see the posting BibTeX loses capitals when creating .bbl file. The upshot: If the string "... The Magic Behind Tiffay & Co ... " occurs in the title field of an entry and if you wish to keep the uppercase letters, they have to be "protected" from being converted to lowercase by encasing the string in curly braces: "... {The Magic Behind Tiffay \& Co} ... ".
    – Mico
    Mar 2, 2022 at 5:35
  • Thank you so much! it worked! Happy March! Mar 2, 2022 at 15:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .