1

I noticed that biblatex is incorrectly creating citations when there are multiple references with the same first author and same year - when using the APA citation style. Specifically, it lists more than one author even though only the first author's last name and et al. should be used.

A short example:

\documentclass[a4paper,twoside,11pt]{report} %openright
\usepackage[onehalfspacing]{setspace}

\usepackage[style=apa, backend=biber]{biblatex} %maxcitenames=1

% Bibliography file
\begin{filecontents}{biblio.bib}
@article{entry1, 
    author = "One Author1 and Two Author2 and Four Author4 and Three Author3",
    title = "Title 1",
    year = "1993",
}
@unpublished{entry2, 
    author = "Author1, One and Author2, Two and Author3, Three and Author4, Four",
    title = "Title 2",
    year = "1993",
}
\end{filecontents}

\addbibresource{biblio.bib}


\begin{document}
\textcite{entry1} \\
\textcite{entry2} \\
\printbibliography
\end{document}

Results in the citations shown below, which incorrectly list three author names. However, APA-7 specifics that references with three or more authors should only use the first authors last name and et al.

enter image description here

2
  • 1
    If I understand correctly, APA style wants this longer list in case the "et al."d citation would be ambiguous. See apastyle.apa.org/style-grammar-guidelines/citations/….
    – moewe
    Mar 15, 2022 at 5:50
  • If you find an error in a biblatex style it is a great idea to report this directly to the developer (in this case via github.com/plk/biblatex-apa/issues). Ideally with an example document (like this one) and a reference to the specific rule that is violated. That way the problem can be fixed by the developer at the source and all users of the style benefit, not only those who notice the issue and search for a solution on the web.
    – moewe
    Mar 15, 2022 at 10:27

2 Answers 2

1

To correctly implement the APA-7 style it is important to set the parameter uniquelist=false:

\usepackage[style=apa, backend=biber, uniquelist=false]{biblatex}

If this option is used, the citations will be correctly formatted, only using the first author name and numbering the years:

enter image description here

Note that it is NOT sufficient to set the maxnames=1 or the likes, as uniquelist=true will override these parameters.

1
  • 2
    It should be unnecessary to set any extra options for the APA style, including uniquelist. The APA stye is quite complex and uses the options in ways which are not quite the same as the generic cases for the options mentioned in the main biblatex documentation - if you think there is an issue here, please open a ticket on the style githib repo. That said, there were some fixes for the latest version (9.16 as of this comment) for the sorts of issue mentioned so try that first.
    – PLK
    Jun 29, 2022 at 13:21
0

While APA style normally wants just the first author + "et al." for works with more than two authors (https://apastyle.apa.org/style-grammar-guidelines/citations/basic-principles/author-date), APA style requires that more names be added in case two citations with different author lists would abbreviate to the same short form (within the same year. See https://apastyle.apa.org/style-grammar-guidelines/citations/basic-principles/same-year-first-author.

In your example biblatex-apa needs to go up to the third name to make the two lists

Author1, Author2, Author3, Author4 1993

Author1, Author2, Author4, Author3 1993

distinct. Because "et al." is always plural, the last name in each list, "Author4" and "Author3", respectively, is mentioned in full.

Currently

\documentclass[a4paper,11pt]{article}
\usepackage[style=apa, backend=biber]{biblatex} 

\begin{filecontents}{\jobname.bib}
@article{entry1, 
  author = {One Author1 and Two Author2 and Four Author4 and Three Author3},
  title  = {Title 1},
  year   = {1993},
}
@unpublished{entry2, 
  author = {Author1, One and Author2, Two and Author3, Three and Author4, Four},
  title  = {Title 2},
  year   = {1993},
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
\textcite{entry1}

\textcite{entry2}

\printbibliography
\end{document}

gives

Author1, Author2, Author4, and Author3 (1993)
Author1, Author2, Author3, and Author4 (1993)

This is correct behaviour according to APA style.

It can be turned off with uniquelist=false,, but then you would not longer be using proper APA style.

Generally speaking, if you think you have found an error in the biblatex-apa implementation of APA style, you should report this issue at https://github.com/plk/biblatex-apa/issues.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .