1

I would like to adapt my reference style to the current journal style. As far as I see, it looks like APA style but not entirely matching. I have prepared a minimal scenario for the current and the desired cases below.

Minimal LaTeX Scenario:

\begin{filecontents}{shortbib.bib}
@article{example,
    author={Chen, Jung Chieh and Wen, Chao Kai and Ting, Pangan},
    journal={IEEE Communications Letters}, 
    title={An Efficient Pilot Design Scheme for Sparse Channel Estimation in OFDM Systems}, 
    year={2013},
    volume={17},
    number={7},
    pages={1352-1355}
}
\end{filecontents}

\documentclass{article}
\usepackage[backend=biber, style=apa]{biblatex}
\addbibresource{shortbib.bib}
\begin{document}
    test text \cite{example}\\
    %\citep{example} > throws an error
    test text (\cite{example})\\
\printbibliography
\end{document}

The language of the desired one is also different. Issues I have detected:

  • Removing the parentheses around the year
  • Removing the & symbol
  • Instead of dot after year, should use comma
  • Need to surround title in quotes
  • Cite with dig. instead of et al. for multiple authors.

I know there are a lot of issues but how can I approach the problem ? I cannot handle it just touching biblatex parameters such as setting style=apa.

enter image description here

Edit/Solutions:

  • I realized that instead of using \cite or \citep, \parencite is great option in order to place a citation together in parenthesis. For more details see.
  • @marquinho 's solution is fab for the language-specific realization. Please see the comment below. \DefineBibliographyStrings{english}{andothers = ve di\u{g}\adddot, volume = Cilt, issue = Sayi}
6
  • biblatex has had a Turkish localization since mid-2020 (v.3.15), which translates strings like "et al." for you. It kicks in if the selected language in the document is turkish. Are you using babel (or polyglossia) for language support on your document? Try \usepackage[turkish]{babel} in the preamble.
    – marquinho
    Commented Mar 17, 2022 at 13:57
  • (See the answers to this question, though, for a common problem with the active character "=" and how to solve it.)
    – marquinho
    Commented Mar 17, 2022 at 14:11
  • @marquinho Unfortunately this is another issue on overleaf. Cannot use \usepackage[turkish]{babel} on there although I have spent a day to handle it. No success for that. However, I solve language encoding side with \usepackage[utf8]{inputenc} and \usepackage[T1]{fontenc}. If I raise this question again, it will probably be downvoted because the same question is already was there but none of answers had solved my case on overleaf. Anyway, I am not able to use \usepackage[turkish]{babel} on my documents :(
    – ozturkib
    Commented Mar 17, 2022 at 14:11
  • @marquinho as I said on my earlier comment, the solution of shorthands is not working on overleaf but not sure other side. I have already tried all previous solutions to change it Turkish. It throws various errors.
    – ozturkib
    Commented Mar 17, 2022 at 14:14
  • 1
    Sorry to hear that :( Well, until (or unless) that can be solved, you can still change the single bib strings manually, while sticking to English. In the preamble, write \DefineBibliographyStrings{english}{andothers = ve di\u{g}\adddot}, this changes "et al." to "ve dig.". This takes a comma-separated list of values: {andothers = ve di\u{g}\adddot, volume = Cilt, issue = Sayi} (hope I got those right :) ) etc. You can find a list of the general keys and their language-specific realization here.
    – marquinho
    Commented Mar 17, 2022 at 14:21

1 Answer 1

2

Support for Turkish was added to the biblatex core in v3.15 (2020-08-16, see e.g. Can I change words in bibliography to Turkish words?, Biblatex turkish bibliography citation support). You just need to account for the babel-turkish making = active: \newgeometry doesn't work with Turkish babel package.

biblatex-apa, however, does not at this point have a Turkish localisation and therefore will not work in a Turkish document.

Since you say you need a style that is only "like APA" but not entirely real APA I strongly suggest you do not use biblatex-apa as a basis for your style. biblatex-apa was specifically written to implement all the idiosyncrasies of APA style and little care is taken to make it customisable.

Here is a start that should reproduce the desired output from the screenshot

\documentclass[turkish]{article}
\usepackage[shorthands=:!]{babel}
\usepackage[
  backend=biber,
  style=ext-authoryear,
  maxbibnames=999,
  mincitenames=1, maxcitenames=2,
  giveninits=true,
  articlein=false,
]{biblatex}

\renewcommand*{\newunitpunct}{\addcomma\space}

\DeclareNameAlias{sortname}{family-given}

\DeclareDelimAlias[bib]{finalnamedelim}{multinamedelim}

\DeclareDelimFormat[bib]{nameyeardelim}{\newunitpunct}

\DeclareFieldFormat{biblabeldate}{#1}

\DeclareFieldFormat
  [article,inbook,incollection,inproceedings,patent,thesis,unpublished]
  {titlecase:title}{\MakeSentenceCase*{#1}}

\renewcommand*{\jourvoldelim}{\addcomma\space}
\renewcommand*{\volnumdelim}{\addcomma\space}
\DeclareFieldFormat[article,periodical]{volume}{\bibcplstring{jourvol}~#1}
\DeclareFieldFormat[article,periodical]{number}{\bibcplstring{issue}~#1}

\begin{filecontents}{\jobname.bib}
@article{example,
  author  = {Chen, Jung Chieh and Wen, Chao Kai and Ting, Pangan},
  journal = {IEEE Communications Letters},
  title   = {An Efficient Pilot Design Scheme
             for Sparse Channel Estimation in {OFDM} Systems},
  year    = {2013},
  volume  = {17},
  number  = {7},
  pages   = {1352-1355},
  langid  = {english},
}
\end{filecontents}
\addbibresource{\jobname.bib}
\addbibresource{biblatex-examples.bib}

\begin{document}
  Lorem \autocite{example}

  dolor \autocite{sigfridsson}

  ipsum \parencite{example}

  sit \cite{example}

  \printbibliography
\end{document}

Lorem (Chen ve di˘ g. 2013)
dolor (Sigfridsson ve Ryde 1998)
ipsum (Chen ve di˘ g. 2013)
sit Chen ve di˘ g. 2013
Chen, J. C., Wen, C. K., Ting, P., 2013, “An efficient pilot design scheme for sparse channel estimation in OFDM systems”, IEEE Communications Letters, Cilt 17, Sayı 7, ss. 1352–1355.

Some relevant questions for the modifications are How to (properly) remove the parentheses around the year in authoryear style? (v3), Suppress "In:" biblatex, Changing type @article to look kind of like @book, Sentence case for titles in biblatex.

More hints for customisation of biblatex styles can be found at Guidelines for customizing biblatex styles and the myriad of specific biblatex questions on this site.

2
  • Fabs! Could you also please add uniquename=init instead of default settings of uniquename=full for the conflict warnings? Any suggestion for the warning of Package csquotes Warning: No style for language 'turkish'. Using fallback style .... In addition, \usepackage[turkish, shorthands=:!]{babel} migth be better if any one using external .cls file.
    – ozturkib
    Commented Mar 20, 2022 at 15:56
  • In addition, could you please add a little bit more comments for each line on your solution? I do not understand every single details to be honest. For instance, author and year do not have comma separator on your suggested code. How can fix it ? There are some other issues but rather than asking I wanna fix it on my own if you put more comments. Huge thanks @moewe
    – ozturkib
    Commented Mar 20, 2022 at 16:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .