I've browsed the forums and found a number of posts that have addressed this issue, but none of the solutions seem to work for me. I have the following script that I just copied from the bibtex home page to get familiar with it. Instead of the citation number I get a question mark. I compile using Latex+Bibtex+Latex+Latex+PDFLatex+ViewPDF just as has been previously suggested and the problem persists.



\title{My Article}
\author{Nobody Jr.}

Blablabla said Nobody ~\cite{Nobody06}.


My bibliography (Bib.bbl)

@misc{ Nobody06,
author = "Nobody Jr",
title = "My Article",
year = "2006" } 

Looking at previous posts one thing that is concerning is that my .bbl looks empty as shown below. Further, I don't have a .blg


  • 19
    not addressing the question itself, ..., but if the ~ before \cite is intended to keep the cross-reference from being broken to a new line, the input shown -- Nobody ~\cite -- won't do that. the space character preceding the ~ will (1) happily allow a line break, and (2) double the width of the space before the xref when it's printed. should be Nobody~\cite to have the no-break effect. Commented Jul 19, 2012 at 17:57

3 Answers 3


Since this question comes up so often, I thought I'd try to supplement ArTourter's correct answer with a more general comment.

What does a question mark mean

It means that somewhere along the line the combination of LaTeX and BibTeX has failed to find and format the citation data you need for the citation: LaTeX can see you want to cite something, but doesn't know how to do so.

Missing citations show up differently in biblatex

If you are using biblatex you will not see a question mark, but instead you will see your citation key in bold. For example, if you have an item in your .bib file with the key Jones1999 you will see Jones1999 in your PDF.

How does this all work

To work out what's happening, you need to understand how the process is (supposed to) work. Imagine LaTeX and BibTeX as two separate people. LaTeX is a typesetter. BibTeX is an archivist. Roughly the process is supposed to run as follows:

  1. LaTeX (the typesetter) reads the manuscript through and gives three pieces of information to BibTeX (the archivist): a list of the references that need to be cited, extracted from the \cite commands; a note of a file where those references can be found, extracted from the \bibliography command; a note of the sort of formatting required, extracted from the \bibliographystyle command.

  2. BibTeX then goes off, looks up the data in the file it has been told to read, consults a file that tells it how to format the data, and generates a new file containing that data in a form that has been organised so that LaTeX can use it (the .bbl file).

  3. LaTeX then has to take that data and typeset the document - and may indeed need more than one 'run' to do so properly (because there may be internal relationships within the data, or with the rest of the manuscript, which BibTeX neither knows or cares about, but which matter for typesetting.

Your question-mark tells you that something has gone wrong with this process.

More biblatex and biber notes

  • If you are using biblatex, the style information is located in the options passed to the to the biblatex package, and the raw data is in the \addbibresource command.

  • If you are using biber, the stage described as BibTeX in this answer is generally replaced with a different, and more cunning, archivist, Biber.

What to do

The first thing to do is to make sure that you have actually gone through the whole process at least once: that is why, to deal with any new citation, you will always need at least a LaTeX run (to prepare the information that needs to be handed to BibTeX), one BibTeX run, and one or more subsequent LaTeX runs. So first, make sure you have done that. Please notice, that latex and bibtex/biber need to be run on your main file (without the file ending). In other words, the basename of your main file: you do not run any commands on the .bib file.

latex MainFile
bibtex MainFile
latex MainFile
latex MainFile

If you still have problems, then something has gone wrong somewhere. And it's nearly always something about the flow of information.

Your first port of call is the BibTeX log (.blg) file. That will usually give you the information you need to diagnose the problem. So open that file (which will be called blah.blg where 'blah' is the name of your source file).

In a roughly logical order:

  1. BibTeX did not find the style file. That's the file that tells it how to format references. In this case you will have an error, and BibTeX will complain I couldn't open the style file badstyle.bst. If you are trying to use a standard style, that's almost certainly because you have not spelled the style correctly in your \bibliographystyle command - so go and check that. If you are trying to use a non-standard style, it's probably because you've put it somewhere TeX can't find it. (For testing purposes, I find, it's wise to remember that it will always be found if it's in the same directory as your source file; but if you are installing using the facilities of your TeX system -- as an inexperienced person should be - you are unlikely to get that problem.)

  2. BibTeX did not find the database file. That's the .bib file containing the data. In that case the log file will say I couldn't open database file badfile.bib, and will then warn you that it didn't find database files. The cure is the same: go back and check you have spelled the filename correctly, and that it is somewhere TeX can find it (if in doubt, put it in the folder with your source file).

  3. BibTeX found the file, but it doesn't contain citation data for the thing you are trying cite. Now you will just get, in the log-file: Warning--I didn't find a database entry for "yourcitation". That's what happened to you. You might think that you should have got a type 2 error: but you didn't because as it happens there is a file called mybib.bib hanging around on the system (as kpsewhich mybib.bib will reveal) -- so BibTeX found where it was supposed to look, but couldn't find the data it needed there. But essentially the order of diagnosis is the same: check you have the right file name in your \bibliography command. If that's all right, then there is something wrong with that file, or with your citation command. The most likely error here is that you've either forgotten to include the data in your .bib file, or you have more than one .bib file that you use and you've sent BibTeX to the wrong one, or you've mis-spelled the citation label (e.g. you've done \cite{nobdoy06} for \cite{nobody06}.

  4. There's something wrong with the formatting of your entry in the .bib file. That's not uncommon: it's easy (for instance) to forget a comma. In that case you should have errors from BibTeX, and in particular something like I was expecting a ',' or a '}' and you will be told that it was skipping whatever remains of this entry. Whether that actually stops any citation being produced may depend on the error; I think BibTeX usually manages to produce something -- but biblatex can get totally stumped. Anyway, check and correct the particular entry.

biblatex and biber notes

If you are using biblatex, then generally you will also be using the Biber program instead of BibTeX program to process your bibliography, but the same general principles apply. Hence the compilation sequence becomes

latex MainFile
biber MainFile
latex MainFile
latex MainFile


The order of diagnosis is as follows:

  1. Have I run LaTex, BibTeX (or Biber), LaTeX, LaTeX?

  2. Look at the .blg file, which will help mightily in answering the following questions.

  3. Has BibTeX/Biber found my style file? (Check whether you have a valid \bibliographystyle command and that there is a .bst with the same name where it can be found.)

  4. Has BibTeX/Biber found my database? (Check the \bibliography names it correctly and it is able to be found.)

  5. Has it found the right database?

  6. Does the database contain an entry which matches the citation I have actually typed?

  7. Is that entry valid?

  8. Finally: When you have changed something, don't forget that you will need to go through the same LaTeX -- BibTeX (or Biber) -- LaTeX -- LaTeX run all over again to get it straight. (That's not actually quite true: but until you have more of a feel for the process it's a safe assumption to make.)

  • 5
    You say it in the first sentence, this question comes very often and now I know where to send people looking for an answer...
    – matth
    Commented Jul 19, 2012 at 9:05
  • fwiw, i'll scrape the answer to improve the faq answer on the same topic (the current faq answer doesn't even touch on biblatex/biber, since i've never used either...). my reuse doesn't add much to the coverage of your work, but it helps me -- ok? Commented Oct 26, 2013 at 18:49
  • 1
    In my case, in most of the times was a missing colon (,), quotation mark ("), or a wrong field.
    – srodriguex
    Commented Apr 25, 2015 at 22:17
  • Thank you very much for the concise explanation. I have always seen the command with several latex but never understood the reason behind it.
    – rkachach
    Commented Feb 11, 2016 at 21:12
  • 3
    Is there a way to automate this? I don't want to have to run latex, then bibtex, then latex twice, everytime I cite something new.
    – a06e
    Commented Oct 31, 2017 at 10:10

The syntax for the \bibliography{} command is \bibliography{file1,file2,...}

in your case you seem to be calling a file called mybib when your bib file is in fact Bib.

Also note that bibtex file should have the .bib extension. the .bbl file will be created by bibtex.

You should therefore rename your bibliography file mybib.bib and get rid of the extra {} in the \bibliography{mybib}{} call, and then recompile. This should fix your problem.

  • 2
    note: if you don't see a .blg file, you likely have not run bibtex yet. latex doesn't process the .bib file directly: it needs to be run once (to create its list of requests for bibtex, then you need to run bibtex to process this list and deliver the requests. Then you can run latex again and it can incorporate these into your output pdf. So assuming a masterfile called masterfile.tex, you need to latex masterfile; bibtex masterfile; latex masterfile Second time, latex will have the files it needs to insert bibtex's output into its own latex output…
    – tim
    Commented Feb 15, 2016 at 23:18

Just one little additional comment. I had the same issue for many days and I struggled to find the solution. Finally, I realized that in the .cls file I had the following library


which I deleted and the problem was solved.

  • please add more info Commented May 29, 2021 at 17:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .