0

Using biblatex+biber, and any of the "verbose" styles, it seems that maxcitenames has no effect. What I would like to achieve is to have citations using \textcite appear with a small number of maxnames, but have the full author list in the corresponding footnote.

Currently I use the following options:

\usepackage[backend=biber,
maxcitenames=2,
maxbibnames=20,
style=verbose-note
]{biblatex} 
Let's cite \textcite{A} here.

I thought this should generate something like the following:

Let's cite Author et al.^1 here.

^1 Author A, Author B, and Author C "Paper title". In Journal, Year.

But instead I get this, as if I had the same large number for both maxcitenames and maxbibnames. Is there a good workaround?

Let's cite Author A, Author B, and Author C^1 here.

^1 Author A, Author B, and Author C "Paper title". In Journal, Year.

MWE:

\documentclass{article}

\begin{filecontents}{test-example.bib}
@article{a,
  author  = {A, Author and B, Author and C, Author},
  title   = {Paper title},
  journal = {Journal A},
  year    = {1921},
}
\end{filecontents}

\usepackage[backend=biber,
maxcitenames=2,
maxbibnames=20,
style=verbose-note
]{biblatex}

\addbibresource{test-example.bib}

\begin{document}
Let's cite \textcite{a} here.
\end{document}
1
  • 1
    Please post a minimal working example in the future so that it is easier to help. I have recreated your issue with a MWE and examined the verbose-note.cbx for an easy solution but could not find any with my limited knowledge. For clarity, maxbibnames only applies to the bibliography, the footnotes are actually \footcite and thus maxcitenames applies to them hence why they print similar numbers. Hope someone more experienced can assist, I think the solution will come from redefining textcite:count or \cbx@textcite@init.
    – user245306
    Mar 27, 2022 at 21:57

1 Answer 1

2

All citations obey the maxcitenames/mincitenames settings, this even includes \fullcite or the first citation in a footnote in a verbose style, which otherwise mimic the bibliography output.

We can make the full citation in the footnote obey maxbibnames/minbibnames instead by redefining the bibmacro footcite:full.

\documentclass{article}

\usepackage[
  backend=biber,
  style=verbose-note,
  maxcitenames=2,
  maxbibnames=20,
]{biblatex}

\makeatletter
\renewbibmacro*{footcite:full}{%
  \usebibmacro{cite:full:citepages}%
  \printtext[bibhypertarget]{%
    \usedriver
      {\defcounter{minnames}{\blx@minbibnames}%
       \defcounter{maxnames}{\blx@maxbibnames}%
       \DeclareNameAlias{sortname}{default}}
      {\thefield{entrytype}}}%
  \usebibmacro{shorthandintro}}
\makeatother

\addbibresource{biblatex-examples.bib}

\begin{document}
\null\vfill % just for the example

Let's cite \textcite{companion} here.

Let's cite \textcite{sigfridsson} here.

Let's cite \textcite{companion} here.
\end{document}

Let’s cite Goossens et al. 1 here.
Let’s cite Sigfridsson and Ryde 2 here.
Let’s cite Goossens et al. 3 here.
1 Michel Goossens, Frank Mittelbach, and Alexander Samarin. The LaTeX Companion. 1st ed. Reading, Mass.: Addison-Wesley, 1994. 528 pp.
2 Emma Sigfridsson and Ulf Ryde. “Comparison of methods for deriving atomic charges from the electrostatic potential and moments”. In: Journal of Computational Chemistry 19.4 (1998), pp. 377–395. doi: 10.1002/(SICI)1096-987X(199803)19:4<377::AID-JCC1>3.0.CO;2-P.
3 Goossens et al., see n. 1.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .