I've googled this (seems to be a problem others are having) and tried numerous things to no avail (including reinstalling both JabRef and MikTEx). 3 hours later I'm broken. My woes started when I deleted MikTex from my system and then reinstalled (I thought I was updating turns out 2.9 was what I had already). Now when I run mikTex no references in my documents will print (The PDF outputs with no reference section and the in text citations are bolded as if they don't exist or JabRef and MikTex aren't communicating).

Thank you in advance.

Here's what I'm using:




I'm using MikTex 2.9 with JabRef 2.8 with winEdt 7 on a win 7 machine. The bib file Psychometrics.bib is located in the directory that the .tex file is located.

Here's the output:

Command Line:   bibtex.exe "example"
Startup Folder: C:\Users\trinker\Desktop\PhD Program\CEP 510 Psychometrics\Assignments\Final paper

This is BibTeX, Version 0.99d (MiKTeX 2.9)
The top-level auxiliary file: example.aux
I found no \citation commands---while reading file example.aux
I found no \bibdata command---while reading file example.aux
I found no \bibstyle command---while reading file example.aux
(There were 3 error messages)

Command Line:   texify.exe --pdf --tex-option=--interaction=errorstopmode --tex-option=--synctex=-1 "C:\Users\trinker\Desktop\PhD Program\CEP 510 Psychometrics\Assignments\Final paper\example.tex"
Startup Folder: C:\Users\trinker\Desktop\PhD Program\CEP 510 Psychometrics\Assignments\Final paper

This is pdfTeX, Version 3.1415926-2.3-1.40.12 (MiKTeX 2.9)
entering extended mode

("C:/Users/trinker/Desktop/PhD Program/CEP 510 Psychometrics/Assignments/Final 
LaTeX2e <2011/06/27>
Babel <v3.8m> and hyphenation patterns for english, afrikaans, ancientgreek, ar
abic, armenian, assamese, basque, bengali, bokmal, bulgarian, catalan, coptic, 
croatian, czech, danish, dutch, esperanto, estonian, farsi, finnish, french, ga
lician, german, german-x-2009-06-19, greek, gujarati, hindi, hungarian, iceland
ic, indonesian, interlingua, irish, italian, kannada, kurmanji, lao, latin, lat
vian, lithuanian, malayalam, marathi, mongolian, mongolianlmc, monogreek, ngerm
an, ngerman-x-2009-06-19, nynorsk, oriya, panjabi, pinyin, polish, portuguese, 
romanian, russian, sanskrit, serbian, slovak, slovenian, spanish, swedish, swis
sgerman, tamil, telugu, turkish, turkmen, ukenglish, ukrainian, uppersorbian, u
senglishmax, welsh, loaded.
Document Class: apa6e 2011/03/03 v0.3 APA 6e manuscript formatting
("C:\MiKTeX 2.9\tex\latex\base\article.cls"
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
("C:\MiKTeX 2.9\tex\latex\base\size12.clo"))
("C:\MiKTeX 2.9\tex\latex\psnfss\times.sty")
("C:\MiKTeX 2.9\tex\latex\psnfss\mathptmx.sty")
("C:\MiKTeX 2.9\tex\latex\geometry\geometry.sty"
("C:\MiKTeX 2.9\tex\latex\graphics\keyval.sty")
("C:\MiKTeX 2.9\tex\generic\oberdiek\ifpdf.sty")
("C:\MiKTeX 2.9\tex\generic\oberdiek\ifvtex.sty")
("C:\MiKTeX 2.9\tex\generic\ifxetex\ifxetex.sty")
("C:\MiKTeX 2.9\tex\latex\geometry\geometry.cfg"))
("C:\MiKTeX 2.9\tex\latex\float\float.sty")
("C:\MiKTeX 2.9\tex\latex\base\ifthen.sty"))
("C:\MiKTeX 2.9\tex\generic\babel\babel.sty"
* Local config file bblopts.cfg used
("C:\MiKTeX 2.9\tex\latex\00miktex\bblopts.cfg")
("C:\MiKTeX 2.9\tex\generic\babel\english.ldf"
("C:\MiKTeX 2.9\tex\generic\babel\babel.def")))
("C:\MiKTeX 2.9\tex\latex\misc\etex.sty"))

Package biblatex Warning: No "backend" specified, using Biber backend.
(biblatex)                To use BibTeX, load biblatex with 
(biblatex)                the "backend=bibtex" option.

("C:\MiKTeX 2.9\tex\latex\oberdiek\kvoptions.sty"
("C:\MiKTeX 2.9\tex\generic\oberdiek\ltxcmds.sty")
("C:\MiKTeX 2.9\tex\generic\oberdiek\kvsetkeys.sty"
("C:\MiKTeX 2.9\tex\generic\oberdiek\infwarerr.sty")
("C:\MiKTeX 2.9\tex\generic\oberdiek\etexcmds.sty"
("C:\MiKTeX 2.9\tex\generic\oberdiek\ifluatex.sty"))))
("C:\MiKTeX 2.9\tex\latex\ltxmisc\url.sty")

Package biblatex Warning: Macro 'reviewauthor' undefined.
(biblatex)                Using \newbibmacro.

) (C:\Users\trinker\AppData\Roaming\MiKTeX\2.9\tex\latex\biblatex-apa\apa.cbx)
 ("C:\MiKTeX 2.9\tex\latex\tools\enumerate.sty")
("C:\MiKTeX 2.9\tex\latex\hyperref\hyperref.sty"
("C:\MiKTeX 2.9\tex\generic\oberdiek\hobsub-hyperref.sty"
("C:\MiKTeX 2.9\tex\generic\oberdiek\hobsub-generic.sty"))
("C:\MiKTeX 2.9\tex\latex\hyperref\pd1enc.def")
("C:\MiKTeX 2.9\tex\latex\00miktex\hyperref.cfg"))

Package hyperref Message: Driver (autodetected): hpdftex.

("C:\MiKTeX 2.9\tex\latex\hyperref\hpdftex.def"
("C:\MiKTeX 2.9\tex\latex\oberdiek\rerunfilecheck.sty"))
("C:\MiKTeX 2.9\tex\latex\graphics\graphicx.sty"
("C:\MiKTeX 2.9\tex\latex\graphics\graphics.sty"
("C:\MiKTeX 2.9\tex\latex\graphics\trig.sty")
("C:\MiKTeX 2.9\tex\latex\00miktex\graphics.cfg")
("C:\MiKTeX 2.9\tex\latex\pdftex-def\pdftex.def")))
("C:\MiKTeX 2.9\tex\latex\base\textcomp.sty"
("C:\MiKTeX 2.9\tex\latex\base\ts1enc.def"))
("C:\MiKTeX 2.9\tex\latex\ams\math\amsmath.sty"
For additional information on amsmath, use the `?' option.
("C:\MiKTeX 2.9\tex\latex\ams\math\amstext.sty"
("C:\MiKTeX 2.9\tex\latex\ams\math\amsgen.sty"))
("C:\MiKTeX 2.9\tex\latex\ams\math\amsbsy.sty")
("C:\MiKTeX 2.9\tex\latex\ams\math\amsopn.sty"))
("C:\MiKTeX 2.9\tex\latex\graphics\color.sty"
("C:\MiKTeX 2.9\tex\latex\00miktex\color.cfg"))
("C:\Users\trinker\Desktop\PhD Program\CEP 510 Psychometrics\Assignments\Final 
paper\example.aux") ("C:\MiKTeX 2.9\tex\latex\base\ts1cmr.fd")
("C:\MiKTeX 2.9\tex\latex\psnfss\ot1ptm.fd")
*geometry* driver: auto-detecting
*geometry* detected driver: pdftex
ABD: EverySelectfont initializing macros
("C:\Users\trinker\Desktop\PhD Program\CEP 510 Psychometrics\Assignments\Final 
paper\example.bbl") ("C:\MiKTeX 2.9\tex\latex\hyperref\nameref.sty"
("C:\MiKTeX 2.9\tex\generic\oberdiek\gettitlestring.sty"))
("C:\Users\trinker\Desktop\PhD Program\CEP 510 Psychometrics\Assignments\Final 
("C:\Users\trinker\Desktop\PhD Program\CEP 510 Psychometrics\Assignments\Final 
[Loading MPS to PDF converter (version 2006.09.02).]
Underfull \hbox (badness 10000) in paragraph at lines 33--33
 []\OT1/ptm/m/n/12 TITLE 

Underfull \hbox (badness 10000) in paragraph at lines 33--33
 []\OT1/ptm/m/n/12 ME 
("C:\MiKTeX 2.9\tex\latex\psnfss\ot1pcr.fd")
Underfull \hbox (badness 10000) in paragraph at lines 33--33
 \OT1/pcr/b/n/14.4 leavefloats \OT1/ptm/b/n/14.4 op-tion be-fore you sub-mit! 

Underfull \hbox (badness 10000) in paragraph at lines 33--33
 []\OT1/ptm/m/n/12 Author Note 
Underfull \hbox (badness 10000) in paragraph at lines 33--33
 [][]\OT1/ptm/m/n/12 Abstract 
! Undefined control sequence.
\HyOrg@maketitle ... \mspart {Abstract}\@abstract 
                                                  \mspart {\@title }
l.33 \cite
Underfull \hbox (badness 10000) in paragraph at lines 33--33
 [][]\OT1/ptm/m/n/12 TITLE 

LaTeX Warning: Citation 'Bennett1954' on page 3 undefined on input line 33.

LaTeX Warning: Citation 'Bennett1954' on page 3 undefined on input line 36.


LaTeX Warning: Empty bibliography on input line 38.

("C:\Users\trinker\Desktop\PhD Program\CEP 510 Psychometrics\Assignments\Final 

LaTeX Warning: There were undefined references.

Package biblatex Warning: Please (re)run Biber on the file:
(biblatex)                example
(biblatex)                and rerun LaTeX afterwards.

(\end occurred when \ifx on line 46 was incomplete)
(\end occurred when \ifx on line 46 was incomplete)
(\end occurred when \ifx on line 46 was incomplete){C:/MiKTeX 2.9/fonts/enc/dvi
ps/fontname/8r.enc}<C:/MiKTeX 2.9/fonts/type1/urw/courier/ucrb8a.pfb><C:/MiKTeX
 2.9/fonts/type1/urw/courier/ucrbo8a.pfb><C:/MiKTeX 2.9/fonts/type1/urw/times/u
tmb8a.pfb><C:/MiKTeX 2.9/fonts/type1/urw/times/utmbi8a.pfb><C:/MiKTeX 2.9/fonts
Output written on example.pdf (3 pages, 51420 bytes).
SyncTeX written on example.synctex.
Transcript written on example.log.
texify: pdflatex.exe failed for some reason (see log file).


 PDFTeXify Compilation Report (Pages: 3)

 Errors: 1   Warnings: 7   Bad Boxes: 6
  • 3
    Just reading the output you posted it starts Command Line: bibtex.exe "example" so you are using bibtex but the warning is printed Package biblatex Warning: No "backend" specified, using Biber backend. (biblatex) To use BibTeX, load biblatex with (biblatex) the "backend=bibtex" option. so you need to tell biblatex that you are using bibtex or use biber (about which I know nothing) Jul 19, 2012 at 21:27
  • 1
    It looks like you're using WinEdt7 and its pdfteXify button. If that's the case, be sure to check the underlying pdftexify macro that it invokes biber rather than bibtex.
    – Mico
    Jul 19, 2012 at 21:58
  • @Mico can you expand slightly on this? Jul 19, 2012 at 22:07
  • 1
    @TylerRinker WinEdt won't run biber for you by default. Ulrike gives some instructions for setting up a menu button here. The options interface got revamped in WinEdt 7, so there might be an easier way. Alternatively you can just run pdflatex and biber from the command line.
    – Audrey
    Jul 20, 2012 at 0:29
  • Update I can run it in MikTex now (reinstalled everything [jabref and MikTex} but it won't work through WinEdt now. I think I'll call this progress for today and will investigate further tomorrow (including Audrey's comment). It was all running well until I reinstalled MikTex :( Jul 20, 2012 at 0:56

3 Answers 3


It looks like you're using WinEdt7 and, in particular, the PDFTeXify button (or the very similar PDFLaTeXify button) to compile your file. The PDF(La)TeXify button is very convenient because it'll run LaTeX, BibTeX (if necessary), and MakeIndex (if necessary) however many times are required to get all cross-references and citations fully resolved. However, as you're discovering, the macro that underlies this "button" runs BibTeX by default even though what's really needed for your LaTeX file is biber.

If you are indeed using this PDFTeXify button, you can proceed by modifying one of the WinEdt macro definition files so that the program invokes biber rather than bibtex. Here's what I suggest you do. In the file PDFTeXify.edt (which governs the behavior of the PDFTeXify "button", there's a call to an environment variable named BibTeX-Executable. This variable, in turn, is assigned a value by the instruction

Assign(!"BibTeX-Executable", !|bibtex.exe|); 

on line 280 of the file ExeMode.edt. (On my system, the file ExeMode.edt is located in the directory ..\WinEdt Team\WinEdt7\Exec\Default\ and is dated 2011/05/20. If you have a different file version, the line in question may also be located somewhere else.)

Change this line to

Assign(!"BibTeX-Executable", !|biber.exe|); 

and save the .edt file. You will probably have to exit and restart WinEdt for this change to take effect.

Addendum -- A word of caution: This change of assignment of the BibTeX-Executable environment variable from bibtex.exe to biber.exe is quite likely going to affect many other processes run by WinEdt. If you are not going to be using biblatex (and biber) exclusively, be on the lookout for strange error messages that may be caused by WinEdt trying to run biber when it should be running bibtex instead.

  • Just to let you know. The PDFLaTeXify button in WinEdt 7/8 comes from an add-on of mine, LaTeXify, which, without changing anything in WinEdt configuration, lets you run pdflatex+biber+makeindex instead of pdflatex+bibtex+makeindex, which is the default behavior for PDFTeXify command. PDFLaTeXify also restores all the values of involved variables. Similar commands for running, e.g., xelatex+biber+makeindex are available in my add-on. Jun 3, 2013 at 10:03

You're one of the first users bitten from the recent update to biblatex, which now uses biber as backend, by default; this is explained in the log file by

Package biblatex Warning: No "backend" specified, using Biber backend.
(biblatex)                To use BibTeX, load biblatex with 
(biblatex)                the "backend=bibtex" option.

So you either use biber instead of BibTeX or say


in your preamble.

However, as Audrey comments, style=apa now requires biber as backend. So you should follow the first road:

biber file

instead of

bibtex file

How to launch biber instead of bibtex depends on what you're using as front-end to LaTeX: TeXworks, TeXStudio or whatnot. Without this information it's impossible to suggest more. However, the following discussion


can help you.

  • Ok this is weird. I added the \usepackage[style=apa,backend=biber]{biblatex} as some suggest and 2 out of 5 times it compiles as it should. 3/5 it does not??? What would cause this? I did not change anythIng in between compiles. Jul 19, 2012 at 21:51
  • I assume biber is like bibtex in that it requires latex biber latex latex and you'd only expect correct output on the third run. Jul 19, 2012 at 22:00
  • 4
    @DavidCarlisle You assume wrong, as biblatex only requires LaTeX, BibTeX, LaTeX :-)
    – Joseph Wright
    Jul 19, 2012 at 22:06
  • @David I can't get this replicate anymore no matter how many time I rerun it. I'm going to shut down and restart. Maybe this will magically fix something. Jul 19, 2012 at 22:06

WinEdt uses BibTeX by default, but in your case should use biber. To make WinEdt 7.0 use biber instead of BibTeX, select the "BibTeX" accessory in the Execution Modes window (Options -> Execution Modes) and in the "Command Line" fields at the bottom, change bibtex.exe to biber.exe.

This is also mentioned in the WinEdt help under the entry for "Execution Modes".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .