38

This is my first time using a LaTeX editor.

I installed Texmaker allowing it to use the default directory on the C drive.

Software Versions

  • Windows: 7 Ultimate 64-bit
  • Texmaker 3.4.1 for Windows

I then did A Local guide for using Texmaker (There use to be a link to this but it is now dead)

Basically create a simple Hello World document and save it.

When I went to process the file

Tools -> PDFLaTeX  

I received

Error: Log file not found!

What I checked

I checked the configuration (Options -> configure Texmaker) and found no option for log files.

I checked for a log file under the C:\Program Files (x86)\Texmaker and found none.

I checked for a log path in the Windows registry using regedit and found none.

I checked the Texmaker issues and found Issue 97 but it does not help.

Any ideas?

After reading answer

I installed MiKTeX as an administrator (didn't work as user) and chose the default options. After MiKTeX installed I was able to create a PDF file using Texmaker.

Also, correctly setting the PDF viewer options

Options -> Configure Texmaker -> Commands -> PDF Viewer
Built-in Viewer and Embed

I was able to preview the pdf in Texmaker

View -> PDF Viewer

What I learned

Texmaker is a LaTeX editor which generates a file containing LaTeX markup.

MiKTeX is a program that converts the LaTeX markup into an output format such as PDF.

34

You also need to install a TeX distribution, i.e. MiKTeX or TeX Live. The TeX distribution contains all the machinery needed to process source code and produce typeset documents; Texmaker is just a front end.

  • Even with MikTex installed, I still get the error. However, I have had success, albeit inconsistently, that running ALL of the updates through the MikTex console resolves the problem. I am guessing there is/are packages that might be contributing to this - even with a bare minimal documentclass begindocument ... – elika kohen Feb 25 at 23:26
  • 1
    @elikakohen --- The best thing to do in these circumstances is try compiling from the command line, i.e. open up whatever terminal windows provides these days, cd into the relevant directory and do pdflatex myfile.tex. If this works then the issue is related to TeXmaker. If it fails then there is a problem with the document, or a package. – Ian Thompson Feb 26 at 17:02
13

It is not enough to just have the TeX distribution installed, it is also necessary to add the MiKTeX bin to the path or else change the commands in the configuration to use the full path to each executable (i.e., if you look at the actual commands being called they are just "latex", "pdflatex", etc. without the path to the executable).

In my case I had MiKTeX installed and working with another editor, but it would not work with TeXMaker - adding the path to the bin to my window Path environment variable resolved the issue for me. For me this path is:

C:\Program Files\MiKTeX 2.9\miktex\bin\x64

4

If you still get error: Log file not found!, when using Texmaker when you have done everything (installed MiKTex, installed Texmaker, and checked if the binary for MiKTeX is already in your windows environment varible) then simply close the Texmaker and reopen it as an administrator. Right click on the executable for Texmaker and "Run as administrator". This worked for me!

  • This does not sound at all safe to me! (Is this safe on Windows? I know Windows is different...) – cfr May 17 '14 at 21:41
  • @cfr - yeah, it is a really bad idea to run programs like this as admin. And, it should be reported as a defect if necessary. – elika kohen Feb 25 at 23:27
1

It is possible in when using a version of Texmaker based on QT5 that you get this error even with you Tex framework available on the path. Make sure that the document you are trying to compile has a .tex prefix, it will not work otherwise.

1

I was using a portable version of miktex with texmaker. Before using the texmaker you need to click on the Miktex box, then a blue box appears at the bottom of your page. Then you can reopen the texmaker and it will work.

1

This also occurs if you already have an install of MikTex but for some reason it gets broken. As happened to me this morning :S The fix is to simply as MikTex to update. It will then tell you there is a problem as it can't find itself, but offers to fix the problem. Update any files you want to update eh Presto, problem solved.

0

I found a work-around!

I have had this problem with both TeXStudio and TeXMaker, (off and on for 6 months+). I have manually updated all kinds of environment variables, uninstalled, reinstalled, and updated every Miktex package, insatalled and ran as admin, (totally a bad idea), made a shared installation, single user, etc.

And yet, I still have the error - which means it's not really either a TexMaker or TexStudio error …

What seems to be working for me, now, is reseting the config, creating a bare minimum document, and then recompiling with the most basic latex compiler, (though the UI). I then go through each of the different compilers until I get to XelaTeX and finally to LuaLaTeX.

I have no idea why, but I am guessing the plain Latex compiler is doing some initializing stuff that the other compilers are having trouble with. (The XeLatex and LUALaTeX compilers seem to be missing an initializing step - and I really think this a defect). I call Voodoo.

Hope this helps.

  • I don't think the sentence in brackets at the end is correct. I suggest posting a new question to get this fixed properly. – Ian Thompson Feb 27 at 7:55
  • @IanThompson - I am not even sure stackexchange is the proper place to get into that. I am thinking a bugreport on MikTex's site would be more helpful. I am 99%-110% certain that it is certainly perhaps not TeXStudio nor TeXMaker that is the source of the issue. But I agree with you that it wouldn't seem like the basic latex compiler is doing something that xetex and lualatex are not... But, I am super new to this toolchain. – elika kohen Feb 27 at 14:23
  • To be absolutely sure what the origin of the problem is, I suggest compiling from the command line, as per my comment above. Integrated development environments do all sorts of weird things, and the only way to be certain that you are free of their evil clutches is to use the command line. – Ian Thompson Feb 28 at 12:29

protected by Mensch Oct 21 '15 at 20:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.