1

I am trying to create some Korean language beginner lessons on LaTeX. I am using the CJKutf8 package for Korean font. It is working in most parts of the document. But when I try to display some random combinations of Korean characters for a practice exercise question, some of the letter-blocks are not displaying. The code is below:

\documentclass{article}
\usepackage{enumerate}
\usepackage{multicol}
\usepackage{CJKutf8} %korean font
\begin{document}
\begin{CJK}{UTF8}{mj}
%Practice Question 1
\begin{multicols}{3}
    \begin{enumerate}
        \item 느
        \item 쳐
        \item 호 
        \item 할
        \item 썈
        \item 뾰
        \item 땨
        \item 숧
        \item 앓
        \item 흃
        \item 뱀
        \item 육
        \item 새
        \item 톁
        \item 핧
        \item 똥
        \item 쯖
        \item 롈
        \item 이
        \item 흙
        \item 밐
        \item 쏖
        \item 왜
        \item 랏
        \item 쨁
        \item 즣
        \item 끃
        \item 쏖
        \item 쏐
        \item 뼻
        \item 떍
        \item 멱
    \end{enumerate}
\end{multicols}
\end{CJK}
\end{document}

The list items not displaying are: 썈, 땨, 숧, 흃, 톁, 핧, 쯖, 롈, 밐, 쏖, 쨁, 즣, 끃, 뼻, 떍

This is the output I am getting:

enter image description here

Can someone help me understand what the problem is and how to solve it?

3
  • Welcome to TeX.SE. Are you at liberty to use either XeLaTeX or LuaLaTeX to compile your document, or are you required to employ pdfLaTeX? Please advise.
    – Mico
    Apr 10, 2022 at 6:45
  • 1
    @Mico Hello and thank you. I am using LaTeK for the first time. I am currently using MikTex with the pdfLaTeX compiler. Since this is a personal project to help me learn so I am at liberty to use either XeLaTeX or LuaLaTeX.
    – FullMoon99
    Apr 10, 2022 at 7:09
  • 1
    @Mico Thanks a lot! Your solution worked really well. Thank you for sharing it.
    – FullMoon99
    Apr 10, 2022 at 8:01

2 Answers 2

0

Since you are free to use XeLaTeX or LuaLaTeX instead of pdfLaTeX, I would like to suggest that you not employ the CJKutf8 package and its CJK environment. Instead, just use XeLaTeX or LuaLaTeX, the fontspec package, and suitable OpenType fonts. In the code below, I use Google's Noto Serif KR and Noto Sans KR font families, which anyone may download and use free of charge. The serif style comes with 7 font weights, and the sans-serif style comes with 6 font weights.

One of the many nice things about using fontspec is that one can easily adjust the default and bold font weights (assuming, of course, that the font provides the desired weights). For instance, in the code below, I don't use the default font weights ("Regular" and "Bold") for Noto Sans KR; instead, I go one step lighter and specify Light and Medium as the arguments of the UprightFont and BoldFont options.

enter image description here

% !TEX TS-program = lualatex
\documentclass{article}
\usepackage{multicol,lipsum,geometry}

\usepackage{fontspec}
\setmainfont{Noto Serif KR}
\setsansfont{Noto Sans KR}[UprightFont = {* Light}, 
                           BoldFont    = {* Medium}]


\begin{document}

%Practice Question 1
\begin{multicols}{3}
    \begin{enumerate}
        \item 느
        \item 쳐
        \item 호 
        \item 할
        \item 썈
        \item 뾰
        \item 땨
        \item 숧
        \item 앓
        \item 흃
        \item 뱀
        \item 육
        \item 새
        \item 톁
        \item 핧
        \item 똥
        \item 쯖
        \item 롈
        \item 이
        \item 흙
        \item 밐
        \item 쏖
        \item 왜
        \item 랏
        \item 쨁
        \item 즣
        \item 끃
        \item 쏖
        \item 쏐
        \item 뼻
        \item 떍
        \item 멱
    \end{enumerate}
\end{multicols}

느 쳐 호 할 썈 뾰 땨 숧 앓 흃 뱀 육 새 톁 핧 똥 쯖 롈 이 흙 밐 쏖 왜 랏 쨁 즣 끃 쏖 쏐 뼻 떍 멱

\textbf{느 쳐 호 할 썈 뾰 땨 숧 앓 흃 뱀 육 새 톁 핧 똥 쯖 롈 이 흙 밐 쏖 왜 랏 쨁 즣 끃 쏖 쏐 뼻 떍 멱}

\textsf{느 쳐 호 할 썈 뾰 땨 숧 앓 흃 뱀 육 새 톁 핧 똥 쯖 롈 이 흙 밐 쏖 왜 랏 쨁 즣 끃 쏖 쏐 뼻 떍 멱}

\textsf{\textbf{느 쳐 호 할 썈 뾰 땨 숧 앓 흃 뱀 육 새 톁 핧 똥 쯖 롈 이 흙 밐 쏖 왜 랏 쨁 즣 끃 쏖 쏐 뼻 떍 멱}}

\medskip
\noindent
\lipsum[1][1-4] % filler text
\end{document}
0

The problem is not from the TeX or LaTeX system, but from the font used by them.

The Korean language uses Hangul letters. Since a Hangul letter is a combination of consonant(s) and a vowel, 11,172 Hangul letters can be made from currently used consonant letters and vowel letters.

However, Most words does not require all of them, and designing a font including all those letters takes so much effort. Therefore, many Korean font designers does not design all 11,172 letters but sufficiently many letters (about 2,350–2,850) which can express the Korean language without most problems. (Of course, there exist many Hangul fonts which supports full 11,172 letters, as shown in Mico's answer.)

The font you used to typeset Hangul seems to contain only the limited number of Hangul letters, and the letters which were not rendered (썈, 땨, 숧, 흃, 톁, 핧, 쯖, 롈, 밐, 쏖, 쨁, 즣, 끃, 뼻, 떍) are not used in Korean Language. The font may not cause problem if they are used in Korean documents, but if they are used in some special situations (such as testing random glyphs), the letters will not show up.

To resolve this problem, you have to use another font that fully provides all Hangul letters. Noto Sans CJK KR, Noto Serif CJK KR, 나눔명조(NanumMyeongjo), 나눔고딕(NanumGothic) are some examples of Hangul fonts that support all 11,172 letters.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .