0

I might have made a big mistake by updating MikTeX after I updated TeXstudio a few weeks before. Now when I try to Build my file, I get the error: "Sorry, but xelatex.exe did not succeed. The log file hopefully contains the information to get MiKTeX going again:"

The indicated log file says this (several times):

2022-04-14 19:02:31,434-0700 FATAL xelatex.core - The memory dump file could not be found.

2022-04-14 19:02:31,434-0700 FATAL xelatex.core - Data: fileName="xelatex.fmt"

2022-04-14 19:02:31,434-0700 FATAL xelatex.core - Source: Libraries\MiKTeX\TeXAndFriends\texmfapp.cpp:717

2022-04-14 19:02:31,434-0700 FATAL xelatex - The memory dump file could not be found.

2022-04-14 19:02:31,434-0700 FATAL xelatex - Info: fileName="xelatex.fmt"

2022-04-14 19:02:31,434-0700 FATAL xelatex - Source: Libraries\MiKTeX\TeXAndFriends\texmfapp.cpp

2022-04-14 19:02:31,434-0700 FATAL xelatex - Line: 717

2022-04-14 19:02:31,450-0700 INFO xelatex - this process (19068) finishes with exit code 1

2022-04-14 19:02:31,450-0700 ERROR xelatex - minor issue: It has been a long time since you have checked for MiKTeX updates.

2022-04-14 19:02:56,274-0700 INFO xelatex - this process (1452) started by 'texstudio' with command line: xelatex.exe -synctex=1 -interaction=nonstopmode ErrorAndUPBmaybeNotLOCC.tex

2022-04-14 19:02:56,305-0700 INFO xelatex - allowing known shell commands

2022-04-14 19:02:56,414-0700 INFO xelatex - going to create file: xelatex.fmt

2022-04-14 19:02:56,507-0700 INFO xelatex.core - start process: initexmf --enable-installer --dump-by-name=xelatex --engine=xetex

2022-04-14 19:03:08,322-0700 ERROR xelatex - C:\Program Files\MiKTeX\miktex\bin\x64\initexmf.exe did not succeed; exitCode: 1

2022-04-14 19:03:08,322-0700 ERROR xelatex - output:

2022-04-14 19:03:08,322-0700 ERROR xelatex - Sorry, but "MiKTeX Configuration Utility" did not succeed.

The log file hopefully contains the information to get MiKTeX going again:

C:\Users\cohen5\AppData\Local\MiKTeX\miktex\log\initexmf.log

I truly hope that I don't have to uninstall and reinstall Texstudio, because I fear it will be a nightmare trying to get everything set back up again the way I have it now.

Thanks in advance for your assistance!

7
  • In TeXstudio, you can create your on profiles in the Options menu. You have only to save your own editor's macros to restore them afterwards. I use pdflatex, (re)-installing TeXstudio is not the main concern, normally issues come from updates from MikTeX.
    – FHZ
    Apr 15 at 2:25
  • @FHZ I don't think I have any editor's macros, at least not that I'm aware of. I assume those would be something I created myself? Also, are you saying all I need do is save profile, uninstall Texstudio, then reinstall it and load the saved profile? Will that get me back to where I used to be?
    – Scott
    Apr 15 at 2:31
  • Yes, your own editor's macros are the ones you created yourself using the menu named macro. They are not the \newcommands (which are also a subset of the set called macros in LaTeX). I recently installed/uninstalled/reinstalled versions 3.1.2 and 4.2.2 and I had no issue regarding TeXstudio. What I can't say for sure is what is causing or why are you having the presented issue.
    – FHZ
    Apr 15 at 2:36
  • OK, I guess I'll have to just give it a shot. The issue only arose immediately after I updated MikTeX. It clearly has something to do with that. Perhaps Texstudio can't find Miktex now, or some such thing like that. Fingers crossed. Thanks much.
    – Scott
    Apr 15 at 2:40
  • One week ago I had a similar issue after updating MikTeX. I used TeXstudio 3.1.2, I tried version 4.2.2. Issue was still there. I revised the upgrade in MikTeX. Reinstall TeXstudio and it worked, but once again, that's not the solution of your issue. The main idea is that TeXstudio is only an editor, it depends of your LaTeX installation (given by MikTeX), not the opposite.
    – FHZ
    Apr 15 at 2:44

1 Answer 1

1

It seems I hadn't actually updated MikTeX, but rather, I had installed a newer version, MikTeX 21.3 to be precise. What I did to fix the issue is, I updated MikTeX through the MikTeX console. Then after reopening TeXStudio, everything seems to work fine, just like it did before installing the newer version of MikTeX.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.