0

I have the following LaTeX code that I use to generate the education section of my resume

\documentclass[a4paper,20pt]{article}

\usepackage{latexsym}
\usepackage[empty]{fullpage}
\usepackage{titlesec}
\usepackage{marvosym}
\usepackage[usenames,dvipsnames]{color}
\usepackage{verbatim}
\usepackage{enumitem}
\usepackage[pdftex]{hyperref}
\usepackage{fancyhdr}

\pagestyle{fancy}
\fancyhf{} % clear all header and footer fields
\fancyfoot{}
\renewcommand{\headrulewidth}{0pt}
\renewcommand{\footrulewidth}{0pt}

% Adjust margins
\addtolength{\oddsidemargin}{-0.530in}
\addtolength{\evensidemargin}{-0.375in}
\addtolength{\textwidth}{1in}
\addtolength{\topmargin}{-.45in}
\addtolength{\textheight}{1in}

\urlstyle{rm}

\raggedbottom
\raggedright
\setlength{\tabcolsep}{0in}

% Sections formatting
\titleformat{\section}{
  \vspace{-10pt}\scshape\raggedright\large
}{}{0em}{}[\color{black}\titlerule \vspace{-6pt}]

%-------------------------
% Custom commands
\newcommand{\resumeItem}[1]{
  \item\small{
    #1 \vspace{-2pt}
  }
}

\newcommand{\resumeItemWithoutTitle}[1]{
  \item\small{
    {\vspace{-2pt}}
  }
}

\newcommand{\resumeSubheading}[4]{
  \vspace{-1pt}\item
    \begin{tabular*}{0.97\textwidth}{l@{\extracolsep{\fill}}r}
      \textbf{#1} & #2 \\
      \textit{#3} & \textit{#4} \\
    \end{tabular*}\vspace{-5pt}
}


\newcommand{\resumeSubItem}[2]{\resumeItem{#1}{#2}\vspace{-3pt}}

\renewcommand{\labelitemii}{$\circ$}

\newcommand{\resumeSubHeadingListStart}{\begin{itemize}[leftmargin=*]}
\newcommand{\resumeSubHeadingListEnd}{\end{itemize}}
\newcommand{\resumeItemListStart}{\begin{itemize}}
\newcommand{\resumeItemListEnd}{\end{itemize}\vspace{-5pt}}

%-----------------------------
%%%%%%  RESUME STARTS HERE  %%%%%%

\begin{document}

%----------HEADING-----------------
\begin{tabular*}{\textwidth}{l@{\extracolsep{\fill}}r}
  \textbf{{\LARGE Shrey Joshi}} & Email: \href{mailto:[email protected]}{[email protected]}\\
  \href{https://shreyjoshi.com}{Website: shreyjoshi.com} & LinkedIn: \href{https://www.linkedin.com/in/sjoshi1729/}{in/sjoshi1729} | 
  \href{https://github.com/xprilion}{GitHub: ~~@shreyj1729} \\
\end{tabular*}

%-----------EDUCATION-----------------
\section{~~Education}
  \resumeSubHeadingListStart
    \resumeSubheading
      {University of Texas at Dallas}{Dallas, Texas}
      {B.S. Computer Science, AES + National Merit Full-ride Scholarship}{2022 - 2025 (Expected)}
    \resumeSubHeadingListEnd

\end{document}

But this results in the following output, where the bullet point is centered between two lines of text. How can I make it so that the bullet point is only on the first bolded line?

enter image description here

4
  • You should post a complete compiliable example rather than making us guess what document class and packages you're using, but have you tried adding the [t] optional parameter to the tabular* environment? \begin{tabular*}{0.97\textwidth}[t]{l@{\extracolsep{\fill}}r}
    – frabjous
    Apr 15, 2022 at 19:38
  • Thanks, just edited it. I tried adding the t option but there seems to be no change unfortunately Apr 15, 2022 at 19:40
  • It works when I try it with your code!
    – frabjous
    Apr 15, 2022 at 19:51
  • Oh, oops, I was putting it in the wrong tabular. Thank you! Do you mind submitting an answer so I can accept it? Apr 15, 2022 at 19:52

1 Answer 1

1

To repeat what I wrote in the comments, you can align the top of the tabular* environment with the surrounding text by adding [t] as the second optional argument to the tabular* enviroment:

\newcommand{\resumeSubheading}[4]{
  \vspace{-1pt}\item
    \begin{tabular*}{0.97\textwidth}[t]{l@{\extracolsep{\fill}}r}
      \textbf{#1} & #2 \\
      \textit{#3} & \textit{#4} \\
    \end{tabular*}\vspace{-5pt}
}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .