1

I am using \RequirePackage{expkv/expkv-opt,expkv/expkv-def} in my sty file. But when I run my tex file I am getting the following error.

This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017/Debian) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
LaTeX2e <2017-04-15>
Babel <3.18> and hyphenation patterns for 84 language(s) loaded.

Document Class: book 2014/09/29 v1.4h Standard LaTeX document class
(/usr/share/texlive/texmf-dist/tex/latex/base/bk10.clo))
(/home/Opstk/vulcan-kmpj/gungadin.sty
(/home/Opstk/vulcan-kmpj/expkv/expkv-opt
.sty
/home/Opstk/vulcan-kmpj/expkv/expkv-opt.
sty:34: Undefined control sequence.
l.34 \IfFormatAtLeastTF
                       {2021/05/01}
? 
/home/Opstk/vulcan-kmpj/expkv/expkv-opt.
sty:34: Emergency stop.
l.34 \IfFormatAtLeastTF
                       {2021/05/01}
/home/Opstk/vulcan-kmpj/expkv/expkv-opt.
sty:34:  ==> Fatal error occurred, no output PDF file produced!
Transcript written on fredholm.log.
/usr/local/bin/texi2dvi: pdflatex exited with bad status, quitting.

Compilation exited abnormally with code 1 at Tue Apr 26 13:13:19
1
  • You omitted the part of the log which would have given the answer, the latex version banner given at the start of every run. Apr 26 at 7:17

1 Answer 1

2

You need to update your TeX installation.

The \IfFormatAtLeastTF built-in was introduced for the October 2020 release. That you have an undefined control sequence means that you are running on an older kernel.

The package you are trying to load wants at least the May 2021 release of TeX to work. Your installation is too old.

8
  • 1
    Or you can add \providecommand\IfFormatAtLeastTF{\@ifl@t@r\fmtversion} to the document. It is recommended that package authors add this to their package before using \IfFormatAtLeastTF if they want compatibility with older LaTeX releases (at least for some time, until LaTeX releases older than 2020-10-01 are nearly extinct) Apr 26 at 1:42
  • Am also getting a problem with \DeclareRelease.
    – Ephram
    Apr 26 at 1:50
  • Same comment as above; but \DeclareRelease was introduced in 2017. So you have a very old TeX kernel running. You absolutely should update your TeX installation to something significantly more current. @Ephram Are you actually using a TeX installation from 2015 ish? Apr 26 at 3:09
  • Quite right. I have This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017/Debian) (preloaded format=pdflatex) restricted \write18 enabled.
    – Ephram
    Apr 26 at 12:55
  • @Ephram It's usually not advised to pull package from different versions. That's not at all guaranteed to work. I'd suggest updating your TeX distribution Apr 26 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.