2

I get the wrong behaviour with this code, using autonum. When one clicks on the hyperlink to the equation it jumps to the beginning of the page.

Minimal (not) working example:

\documentclass{book}
\usepackage[paperheight=9in,paperwidth=6in]{geometry}
\usepackage{amsmath}
\usepackage{mathtools}%\mathtoolsset{showonlyrefs}
\usepackage{lipsum}
\usepackage[colorlinks, breaklinks, citecolor=green, linkcolor=red,urlcolor=red, unicode,psdextra]{hyperref}
\usepackage{cleveref}
\usepackage{autonum}
\usepackage{lipsum} 
\crefname{equation}{}{}
\begin{document}
\begin{equation}
    a-b
\end{equation}
\lipsum[1-10]
\begin{equation}
    \label{eq} (a+b)^2
\end{equation}
\lipsum[1-10]
\eqref{eq}
\end{document}

Can someone help fix this, please?

1 Answer 1

1

As the user guide of the autonum package explains, you need to load the hyperref package with the option hypertexnames=false. I would therefore change

\usepackage[colorlinks, breaklinks, citecolor=green, linkcolor=red,
   urlcolor=red, unicode,psdextra]{hyperref}

to

\usepackage[colorlinks, citecolor=green, linkcolor=red,
     urlcolor=red, psdextra, hypertexnames=false]{hyperref}

Aside: Are you absolutely sure you need to set the option psdextra? (Note that I've already gone ahead and deleted the options breaklinks and unicode...)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.