I installed a new hard drive, moved my Win10 installation and all data over to it. Got a clean reinstall of TeXstudio and MiKTeX. I made my bibliography using biblatex and ever since the change to the new HDD, it no longer compiles citations that have umlauts in their bibliography ID.

\author{None other than Me}
\title{Something to test}
    According to \cite{Antifungal-LAB-Propioni-Biopreservation}, this is true. But \cite{Probiotika-präbiotika-def-einsatz,Hausschlacht-NubaRohPök} disagree.

It produces this log upon compilation:

Process started: "C:\Program Files\MiKTeX 2.9\miktex\bin\x64\biber.exe"  "testing"

INFO - This is Biber 2.17
INFO - Logfile is 'testing.blg'
INFO - Reading 'testing.bcf'
INFO - Found 3 citekeys in bib section 0
INFO - Processing section 0
INFO - Looking for bibtex file 'quellenBA.bib' for section 0
INFO - LaTeX decoding ...
INFO - Found BibTeX data source 'quellenBA.bib'
INFO - Overriding locale 'de-DE' defaults 'variable = shifted' with 'variable = non-ignorable'
INFO - Overriding locale 'de-DE' defaults 'normalization = NFD' with 'normalization = prenormalized'
INFO - Sorting list 'nty/global//global/global' of type 'entry' with template 'nty' and locale 'de-DE'
INFO - No sort tailoring available for locale 'de-DE'
INFO - Writing 'testing.bbl' with encoding 'UTF-8'
INFO - Output to testing.bbl
WARN - I didn't find a database entry for 'Probiotika-pr^^c3^^a4biotika-def-einsatz' (section 0)
WARN - I didn't find a database entry for 'Hausschlacht-NubaRohP^^c3^^b6k' (section 0)
Process exited normally

Process started: "C:\Program Files\MiKTeX 2.9\miktex\bin\x64\pdflatex.exe"  -synctex=1 -interaction=nonstopmode "testing".tex

Process exited normally

Process started: "C:\Program Files\MiKTeX 2.9\miktex\bin\x64\pdflatex.exe"  -synctex=1 -interaction=nonstopmode "testing".tex

Process exited normally

And it gives me this output:

enter image description here

I understand that the two warnings mean that it thinks there are no database entries. But there are, it just tries finding the entry with their umlauts written that way. The corresponding .bib entries are:

    title = {Antifungal lactic acid bacteria and propionibacteria for food biopreservation},
    editor = {Lacroix, C.},
    booktitle = {Protective Cultures, Antimicrobial Metabolites and Bacteriophages for Food and Beverage Biopreservation},
    publisher = {Woodhead Publishing},
    pages = {27-62},
    year = {2011},
    series = {Woodhead Publishing Series in Food Science, Technology and Nutrition},
    doi = {10.1533/9780857090522.1.27},
    url = {https://www.sciencedirect.com/science/article/pii/B9781845696696500029},
    author = {S. Miescher Schwenninger and L. Meile and C. Lacroix},

    author = {Schulz, S. and Kunz, C.},
    title = {Probiotika, Präbiotika, Colonic food Definitionen und mögliche Einsatzgebiete},
    journal = {Monatsschrift Kinderheilkunde},
    doi = {10.1007/s00112-002-0507-y},
    year = {2002},
    pages = {808 - 816},

    author = {o.N.},
    title = {Reifekulturen zur Herstellung von Rohschinken},
    url = {https://hausschlachtebedarf.de/gewuerze/zusatzstoffe/2133/30-g-reifekulturen-zur-herstellung-von-rohschinken?c=3},
    note = {zuletzt geöffnet: 21.03.2022},
    organization = {Nubassa},

It used to work without any issue and I changed nothing on the file itself after migrating to a new HDD.

I tried searching for answers online, but all my BibLaTeX questions seem to point me to questions related to Biber that don't seem to give a solution to my problem.

  • You have umlauts in your bib key, which requires that you use an Engine with native UTF8-support, e.g. LuaLaTeX. Are you using pdfLaTeX by any chance? ETA: Yes, you are: Process started: "C:\Program Files\MiKTeX 2.9\miktex\bin\x64\pdflatex.exe. Try switching.
    – Ingmar
    Commented May 2, 2022 at 13:56
  • 1
    @Ingmar in the past it would have been a problem, but umlauts no longer expand when written to a file (if utf8 is used). That's why they are now safe e.g. in \label and also (mostly) in \cite Commented May 2, 2022 at 14:01
  • 1
    hm. the only obvious difference I see is that you have older binaries. You have Version 3.14159265-2.6-1.40.21 (MiKTeX 20.7), while I have 3.141592653-2.6-1.40.24 (MiKTeX 22.3). Commented May 2, 2022 at 19:18
  • 1
    if there are no updates something is wrong with your system. You clearly use an rather old binary. In your log article.cls is from C:\Users\crota\AppData\Local\Programs\MiKTeX\tex/latex/base\article.cls, that means you installed in single user mode and there should be no admin mode in the console. Check if you have two tex systems. Commented May 3, 2022 at 7:21
  • 2
    I finally solved it. Somehow I had two MiKTeX installations on the same drive and TeXstudio accessed the older one, I presume. When I set the path for each of the commands (the one you find in Configure TeXstudio -> Commands) to the proper target, it finally worked as it should. Thank you all for persevering through this hellhole with me!
    – Crotaro
    Commented May 3, 2022 at 18:08

1 Answer 1


In my case, the solution was that I had two MiKTeX installations on my drive (no real idea where or when the "wrong one" came to be). I changed the path for each command in Configure TeXstudio -> Commands to the correct target (meaning, I just changed to MiKTeX folder, really, since everything else was the same). Now it works flawlessly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .