1

lwarp automatically generates a side TOC for each separate page. I find this annoying and do not want it. But I am not able to find any option reading the manual how to turn it off. I would prefer to have a normal table of content for the local page if possible. But that seems not a feature of lwarp.

So how to disable the generate of the side toc? Here is a MWE

\documentclass{book}
\usepackage[mathjax]{lwarp}
\setcounter{FileDepth}{2} 
%\setcounter{SideTOCDepth}{2} %comment this or not, has no effect

\begin{document}
\title{my page}
\author{me}
\date{\today}
\tableofcontents

\chapter{this is chapter 1} 
\section{my first section} 
\subsection{my first subsection}
   text

\end{document}

And now

lualatex foo.tex
lualatex foo.tex
lwarpmk html

And clicking on chapter on the page gives

enter image description here

It shifts the whole page to the right and it is small and hard to read and for a very long page, it becomes hard to scroll and use it and I find it annoying being there.

If there an option to remove it?

TL 2022

1 Answer 1

2

Probably the easiest way is to fix it in post by removing it from display. Add

.sidetoccontainer {
    display: none;
}

to your CSS file. Copy the lwarp_*.css file that you want to use to some other name, say lwarp_custom.css, add the rule above at the end of the file, and then include \CssFilename{lwarp_custom.css} so that this is used by the output of lwarp. The sidetoc contents will still be in the HTML but it will not be seen and will not get in the way.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .