0

I am trying to install MiKTeX on a new macOS system. Each time that I try to compile any .tex file, I get the following error:

jwalsh23@Jacks-MacBook-Pro-14 $ pdflatex CV.tex
This is pdfTeX, Version 3.141592653-2.6-1.40.24 (MiKTeX 22.1) (preloaded format=pdflatex.fmt)
 restricted \write18 enabled.

Sorry, but pdflatex did not succeed.

The log file hopefully contains the information to get MiKTeX going again:

  /Users/jwalsh23/Library/Application Support/MiKTeX/texmfs/data/miktex/log/pdflatex.log

The specified logfile contains the following:

2022-05-18 19:04:30,819-0400 INFO  pdflatex - this process (3654) started by bash in directory /Users/jwalsh23/Downloads with command line: pdflatex CV.tex
2022-05-18 19:04:30,819-0400 INFO  pdflatex - this is MiKTeX-PDFTEX 4.10.0 (1.40.24) (MiKTeX 22.1)
2022-05-18 19:04:30,819-0400 INFO  pdflatex - allowing known shell commands
2022-05-18 19:04:30,823-0400 INFO  pdflatex - going to create file: pdflatex.fmt
2022-05-18 19:04:30,837-0400 INFO  pdflatex.core - forking...
2022-05-18 19:04:31,168-0400 ERROR pdflatex - /Users/jwalsh23/bin/miktex did not succeed; exitCode: 1
2022-05-18 19:04:31,169-0400 ERROR pdflatex - output:
2022-05-18 19:04:31,169-0400 ERROR pdflatex - 
Sorry, but: The executed process did not succeed.

2022-05-18 19:04:31,169-0400 FATAL pdflatex.core - The memory dump file could not be found.
2022-05-18 19:04:31,169-0400 FATAL pdflatex.core - Data: fileName="pdflatex.fmt"
2022-05-18 19:04:31,169-0400 FATAL pdflatex.core - Source: Libraries/MiKTeX/TeXAndFriends/texmfapp.cpp:717
2022-05-18 19:04:31,169-0400 FATAL pdflatex - The memory dump file could not be found.
2022-05-18 19:04:31,169-0400 FATAL pdflatex - Info: fileName="pdflatex.fmt"
2022-05-18 19:04:31,169-0400 FATAL pdflatex - Source: Libraries/MiKTeX/TeXAndFriends/texmfapp.cpp
2022-05-18 19:04:31,169-0400 FATAL pdflatex - Line: 717
2022-05-18 19:04:31,170-0400 INFO  pdflatex - this process (3654) finishes with exit code 1

I have tried reinstalling MiKTeX several times, running miktexsetup cleanup, I've tried using an admin installation as well as a user installation, nothing seems to work.

3
  • 1
    any particular reason to be using miktex here? the vast majority of mac users will be using mactex (texlive) so easier to get help when things go wrong. May 18 at 23:16
  • 1
    Welcome to SE. I wouldn't choose MikTeX as a distribution for macOS, honestly. If someone else can't help you find what specific problem you have, I'd recommend installing MacTeX instead.
    – Miyase
    May 18 at 23:16
  • you need to find out, why the format can't be created. There should be a log for it in one of the roots (on windows I have them in ....\AppData\Local\MiKTeX\2.9\miktex\log\makefmt\pdflatex) May 19 at 7:19

1 Answer 1

1

I have run into this problem once when I update the MiKTeX. Finally, I figured it out that You have to give "miktex console" administrate authority. The solution is:

run you "MiKTeX Console.app", then choose operation mode as administration mode instead of user mode, update packages and so on.

Then, the app should work as before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.