Recently, I changed from using MiKTeX to TeX Live for easier sharing of setup & settings between PC's in our network. Most of the setup worked perfectly fine, but while trying to migrate our dvipdfmx settings I ran into some weird issues with it's image caching.

I have an I 120 directive in the dvipdfmx.cfg file to preserve pdf's generated from eps-files by GhostScript. This used to work fine and still works fine in most cases, but some images seem to cause building to fail. This results in xelatex reporting Error -1073741819 (driver return code) generating output; in the log (on second and further runs, when cache is used).

While narrowing this down by first running xelatex to generate a dvi file, then using dvipdfmx manually to create a pdf, I found out that dvipdfmx seems to be crashing, but only on a small selection of paths. I have yet to find a clear cause on what paths seem to be crashing.





Paths that also seem to be failing:

  • C:/Users/<User>/Documents/test_test

Paths I tried that did work fine with cache:

  • Relative paths test, test__, test___, test_test_test
  • C:/LaTeX/test_test
  • C:/Users/<User>/Documents/test
  • C:/Users/<User>/Documents/testtesttest
  • C:/Windows/some_really_really_really_really_really_really_really_really_long_file_name


xelatex tex > dvi:

>> xelatex -no-pdf "simple".tex
This is XeTeX, Version 3.141592653-2.6-0.999994 (TeX Live 2022) (preloaded format=xelatex)
 restricted \write18 enabled.
entering extended mode
LaTeX2e <2021-11-15> patch level 1
L3 programming layer <2022-05-04>
Document Class: article 2021/10/04 v1.4n Standard LaTeX document class
ef) (./simple.aux)
Overfull \hbox (185.92749pt too wide) in paragraph at lines 7--8
[1] (./simple.aux) )
(see the transcript file for additional information)
Output written on simple.xdv (1 page, 512 bytes).
Transcript written on simple.log.

dvipdfmx dvi > pdf (first run):

>> dvipdfmx -vv -o simple.pdf simple.xdv
DVI Comment:  XeTeX output 2022.05.20:1649
simple.xdv -> simple.pdf
pdf_image>> Converting file "./test_test.eps" --> "C:/Users/<User>/AppData/Local/Temp/dvipdfm-x.45ecbe5f03d4fb86cdf0de8b3107c654" via:
pdf_image>>   rungs -q -dPDFSETTINGS=/prepress -dEmbedAllFonts=true -dSAFER -dNOPAUSE -dBATCH -dEPSCrop -sPAPERSIZE=a0 -sDEVICE=pdfwrite -dCompatibilityLevel=%v -dAutoFilterGrayImages=false -dGrayImageFilter=/FlateEncode -dAutoFilterColorImages=false -dColorImageFilter=/FlateEncode -dAutoRotatePages=/None -sOutputFile='%o' '%i' -c quit
pdf_image>> ...,Page:1)<//servername/latex/texlive/2022/texmf-dist/fonts/opentype/public/lm/[email protected]<NATIVE-FONTMAP://servername/latex/texlive/2022/texmf-dist/fonts/opentype/public/lm/lmroman10-regular.otf/0/H/65536/0/0>
fontmap: //servername/latex/texlive/2022/texmf-dist/fonts/opentype/public/lm/lmroman10-regular.otf/0/H/65536/0/0 -> //servername/latex/texlive/2022/texmf-dist/fonts/opentype/public/lm/lmroman10-regular.otf(Identity-H)
pdf_font>> Type0 font "//servername/latex/texlive/2022/texmf-dist/fonts/opentype/public/lm/lmroman10-regular.otf" cmap_id=<Identity-H,0> font_id=<//servername/latex/texlive/2022/texmf-dist/fonts/opentype/public/lm/lmroman10-regular.otf/0/H/65536/0/0,1>.
otf_cmap>> Creating ToUnicode CMap for "//servername/latex/texlive/2022/texmf-dist/fonts/opentype/public/lm/lmroman10-regular.otf"...
://servername/latex/texlive/2022/texmf-dist/fonts/opentype/public/lm/lmroman10-regular.otf[LMRoman10-Regular][CIDFontType0][2 glyphs][553 bytes]
Compression saved 16271 bytes
20959 bytes written

dvipdfmx dvi > pdf (second run trying to use cache, crashes):

>> dvipdfmx -vv -o simple.pdf simple.xdv
DVI Comment:  XeTeX output 2022.05.20:1649
simple.xdv -> simple.pdf

Version info:

>>xelatex --version
XeTeX 3.141592653-2.6-0.999994 (TeX Live 2022)
kpathsea version 6.3.4
Copyright 2022 SIL International, Jonathan Kew and Khaled Hosny.
There is NO warranty.  Redistribution of this software is
covered by the terms of both the XeTeX copyright and
the Lesser GNU General Public License.
For more information about these matters, see the file
named COPYING and the XeTeX source.
Primary author of XeTeX: Jonathan Kew.
Compiled with ICU version 70.1; using 70.1
Compiled with zlib version 1.2.11; using 1.2.11
Compiled with FreeType2 version 2.11.1; using 2.11.1
Compiled with Graphite2 version 1.3.14; using 1.3.14
Compiled with HarfBuzz version 3.4.0; using 3.4.0
Compiled with libpng version 1.6.37; using 1.6.37
Compiled with pplib version v2.05 less toxic i hope
Compiled with fontconfig version 2.13.96; using 2.13.96

>>dvipdfmx --version
This is dvipdfmx Version 20211117 by the DVIPDFMx project team,
modified for TeX Live,
an extended version of dvipdfm-0.13.2c developed by Mark A. Wicks.

Copyright (C) 2002-2021 the DVIPDFMx project team
Copyright (C) 2006-2021 SIL International.

This is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.

>> systeminfo
OS Name:                   Microsoft Windows 11 Home
OS Version:                10.0.22000 N/A Build 22000


Anyone has any idea about the possible cause, and if there is some way to counter this? I'm kind of lost which files will be affected, and how to solve this on my end or wether or not this is some kind of bug.

Update 2022/06/07: problem seems to be limited to Windows 11 machines.

  • I just managed to reproduce this on another machine. However, when trying to compile + convert the same file on a Windows 10 machine, I encountered no problems. So it seems the problem is limited specifically to Windows 11. Anyone happens to have any clue what could be the problem here?
    – JesperN
    Jun 7, 2022 at 10:27

1 Answer 1


Seemed to be a bug in the dvipdfmx source code, which was recently solved.

See also https://tug.org/pipermail/dvipdfmx/2022-June/000342.html and https://www.tug.org/svn/texlive?view=revision&revision=63566.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .