I ran the TeX Live 2012 update this morning on my 64-bit Kubuntu 12.04 linux system (tlmgr update --all) and received the following error:

tlmgr: package log updated at /usr/local/texlive/2012/texmf-var/web2c/tlmgr.log
running mktexlsr ...
done running mktexlsr.
running mtxrun --generate ...
done running mtxrun --generate.
running updmap-sys ...

updmap-sys failed (status 1), output:
updmap is using the following updmap.cfg files (in precedence order):
dvips output dir: "/usr/local/texlive/2012/texmf-var/fonts/map/dvips/updmap"
pdftex output dir: "/usr/local/texlive/2012/texmf-var/fonts/map/pdftex/updmap"
dvipdfmx output dir: "/usr/local/texlive/2012/texmf-var/fonts/map/dvipdfmx/updmap"
pxdvi output dir: "/usr/local/texlive/2012/texmf-var/fonts/map/pxdvi/updmap"

ERROR:  The following map file(s) couldn't be found:
        ${PKGNAME}.map (in /usr/local/texlive/2012/texmf-dist/web2c/updmap.cfg)

        Did you run mktexlsr?

        You can disable non-existent map entries using the option

tlmgr: exiting unsuccessfully (status 1).

Running updmap-sys --syncwithtrees gives the following:

david@dd:~$ updmap-sys --syncwithtrees
updmap is using the following updmap.cfg files (in precedence order):
Missing map files found, disabling
        ${PKGNAME}.map (in /usr/local/texlive/2012/texmf-dist/web2c/updmap.cfg)
in /usr/local/texlive/2012/texmf-config/web2c/updmap.cfg
Do you really want to continue (y/N)? y
answer =y=
Creating new config file /usr/local/texlive/2012/texmf-config/web2c/updmap.cfg
Use of uninitialized value in subroutine entry at /usr/local/texlive/2012/bin/x86_64-linux/updmap line 1332,  line 1.
Can't use string ("") as a subroutine ref while "strict refs" in use at /usr/local/texlive/2012/bin/x86_64-linux/updmap line 1332,  line 1.

I'm lost at this point. Can anyone at TUG help?

4 Answers 4


This seems to be a recently reported problem, and I suspect there will be a more permanent fix distributed, (as confirmed by Norbert's answer) but for the moment, edit the file (you will probably need to use an editor that allows you to authenticate to save, or invoke your editor with sudo.)


In it you will find a line


As egreg notes in the comments, this is an error in the bguq, so you can change this line to


and save the file. Then run:

sudo updmap-sys

And you should be fine.

  • The culprit is bguq, for which the corresponding bguq.tlpsrc file says execute addMap ${PKGNAME}.map. Changing the entry in updmap.cfg to bguq.map and running sudo updmap-sys solves the problem in the immediate.
    – egreg
    Commented Jul 24, 2012 at 19:49
  • Thanks ! I had the same problem with MacTeX 2012 and your fix does the trick. Commented Jul 25, 2012 at 6:29
  • I owe you a beer, Alan. :) Commented Jul 25, 2012 at 12:21

Fixed already in today's update. For those who had the same problem, just wait until the respective CTAN mirror is updated.


I had the same problem and simply changed the repository source, which then deinstalled some packages I didn't care about and then the updating worked fine. So just change your source.

  • Thanks, Hurwicz! I tried Alan's suggestion, and that seemed to fix the problem.
    – DPLentini
    Commented Jul 24, 2012 at 19:55

My understanding is that --syncwithtrees is not recommended for Debian type distributions (including Kubuntu). I had a similar problem and traced it to a missing tipa.map file which was resolved with apt-get install tipa.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .