0

I am running TexShop on a 2 year old Mac, running Catalina. I haven't worked on a file in a while, but I did update TexShop, and now I am having problems.

One problem is, if I try to typeset a LaTeX file, I get an error like:

This is pdfTeX, Version 3.141592653-2.6-1.40.24 (TeX Live 2022) (preloaded format=pdflatex) restricted \write18 enabled. entering extended mode (./notes2.ltx/Library/TeX/texbin/pdflatex: getcwd: Operation not permitted

If I move the file to my main Desktop folder, it will typeset correctly. If I try to typeset a LaTeX file in a different folder, that already has the .aux, .log, and .pdf files, I get an error of the form:

./Sym4notes.tex:0: I can't write on file Sym4notes.log'. (Press Enter to retry, or Control-D to exit; default file extension is .log')Please type another transcript file name:

So, to typeset correctly, I need to move or create a new LaTeX file in my main Desktop folder only.

I originally upgraded to version 4.72.

I then uninstalled Texshop, and uninstalled the Tex folder that is created from MacTex. I downloaded and installed MacTex, and this came with TexShop version 4.70.

7
  • Welcome to TeX SE! This may be helpful: tex.stackexchange.com/questions/511617/… May 26, 2022 at 16:36
  • Does it really say ./notes2.ltx/Library/TeX/texbin/pdflatex? It looks like you are not using the standard data structures for finding the binaries. In TeXShop->Preferences got to the Engine tab and make sure that the Path settings for (pdf)TeX is set to /Library/TeX/texbin. May 26, 2022 at 16:39
  • Yes, it really does say that. notes2 was the name of the latex file.
    – markers17
    May 26, 2022 at 17:57
  • /Library/TeX/texbin is the path in my settings for (pdf)Tex
    – markers17
    May 26, 2022 at 17:58
  • I uninstalled version 4.70 of TeXShop, and then installed version 4.44. This seems to have fixed the problem completely. I don't know what was causing the problem for versions 4.70 and 4.72. I can still work with 4.44, but would like to use the latest version. Herb... thanks for responding, but I don't think that was the cause.
    – markers17
    May 26, 2022 at 18:03

1 Answer 1

0

My brand new MacBook Air (M2,2022) Version 12.5.1 with Apple M2 chip had the same problem. So I did move the file to the desktop as you said, and asked it to typeset. It asked me for permission to access the desktop folder and I hit yes, and the problem disappeared. It now typesets fine even with files anywhere else on my computer. Mystery. But happy it got resolved. So perhaps you need to somehow give TexShop access to the folder where you have your file. Anne Dow

1
  • I spoke too soon. It is now not working again for files outside the desktop. Don't know why it worked for a while. Anne Dow
    – Anne Dow
    Sep 5, 2022 at 2:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .