2

I've tried to upgrade to REVTeX 4.1 but am getting compile error even with the simplest document:

\documentclass{revtex4-1}
\filelist
\begin{document}
test
\end{document}

produces:

...snip...
! LaTeX Error: Command \url already defined.
               Or name \end... illegal, see p.192 of the manual.
...snip...

Did I install improperly, or is this a bug?

EDIT (Requested file list):

 *File List*
revtex4-1.cls    2010/07/25/20:33:00 4.1r (http://publish.aps.org/revtex4/ for documentation)
  aps4-1.rtx
aps10pt4-1.rtx
textcase.sty    2004/10/07 v0.07 Text only upper/lower case changing (DPC)
     url.sty    1999/03/02  ver 1.4  Verb mode for urls, email addresses, and file names
  natbib.sty    2007/02/05 8.0 (PWD)
revsymb4-1.sty    2010/07/25/20:33:00 4.1r (http://publish.aps.org/revtex4/ for documentation)
 ***********
5
  • Did you delete any stray .aux files? Could you \listfiles for us: I have no issues.
    – Joseph Wright
    Jul 24, 2012 at 20:01
  • I don't get any error. Can you show the part of the log file that you get from *File List* to the end when adding \listfiles at the very beginning of the document?
    – egreg
    Jul 24, 2012 at 20:06
  • @JosephWright and egerg: Done. Jul 24, 2012 at 20:32
  • Do you have any .bbl file from a previous version of your document? If so, try deleting the .bbl file. Jul 24, 2012 at 20:39
  • I think that I had the class installed incorrectly or had some lingering .aux file. anyhow, I recompiled on a different machine and it worked fine...sorry for the trouble. Aug 7, 2012 at 5:02

1 Answer 1

1

(More of a comment, but too long)

This is 'works for me' with TeX Live 2012, and I get file list

 *File List*
revtex4-1.cls    2010/07/25/20:33:00 4.1r (http://publish.aps.org/revtex4/ for 
documentation)
  aps4-1.rtx
aps10pt4-1.rtx
textcase.sty    2004/10/07 v0.07 Text only upper/lower case changing (DPC)
     url.sty    2006/04/12  ver 3.3  Verb mode for urls, etc.
  natbib.sty    2010/09/13 8.31b (PWD, AO)
revsymb4-1.sty    2010/07/25/20:33:00 4.1r (http://publish.aps.org/revtex4/ for
 documentation)

My immediate suspicion would be the version of natbib you are using.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.