1

I'm working on macOS Monterey (version 12.3) and just did a fresh install of TexStudio (version 4.2.3). When I try to change some editor settings (e.g., the color scheme) I get the following message upon closing the program:

Storing session information into /Users/MyName/.config/texstudio/lastSession.txss2 failed. File exists but is not writeable.

If I then reopen TexStudio, the visual styling is all default, so my changes did not take. When I check this directory in Terminal I see that /.config doesn't even contain a texstudio directory.

Any ideas on how to fix this?

2
  • What are the permissions on ~/.config? Does manully creating ~/.config/texstudio help at all?
    – frabjous
    May 31, 2022 at 14:49
  • "system" has read & write permissions, and while the ~/.config/texstudio directory did not originally exist, after I created that directory I continue to get the same error.
    – pQ12branch
    May 31, 2022 at 15:45

1 Answer 1

3

I had the exact same issue with texstudio. I resolved this problem by manually entering the .config folder and creating a new folder named "texstudio". After doing so, texstudio was able to save changed settings again. In order to access this folder on a mac use the shortcut cmd + shift + g, then access the path ~/.config.

1
  • This answer must be marked as the solution, worked perfectly!
    – cemal
    Apr 1 at 22:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .