0

I’ve spent a bit trying to debug this, but wanted to make sure it wasn’t a known bug before killing myself.

I’m trying to use the \longdivision{} command in a LaTeXit equation. It’s alone in the equation, and I have \usepackage{longdivision} in the header.

Used alone (\longdivision{2345}{9999}) all is well. When I add separators in work (\longdivision[separators in work = false]{2345}{9999}), I get an error Missing number, treated as zero. I’ve tried in standard and text modes.

I’ve also tried in an absolutely vanilla TeX document and get a similar error.

\documentclass{article}
\usepackage{longdivision}

\longdivision[separators in work = false]{14.1}{3}
\end{document}

gives

This is pdfTeX, Version 3.14159265-2.6-1.40.21 (TeX Live 2020) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
(./Untitled.tex
LaTeX2e <2020-02-02> patch level 5
L3 programming layer <2020-03-06>
(/usr/local/texlive/2020/texmf-dist/tex/latex/base/article.cls
Document Class: article 2019/12/20 v1.4l Standard LaTeX document class
(/usr/local/texlive/2020/texmf-dist/tex/latex/base/size10.clo))
(/usr/local/texlive/2020/texmf-dist/tex/latex/longdivision/longdivision.sty
(/usr/local/texlive/2020/texmf-dist/tex/latex/l3packages/xparse/xparse.sty
(/usr/local/texlive/2020/texmf-dist/tex/latex/l3kernel/expl3.sty
(/usr/local/texlive/2020/texmf-dist/tex/latex/l3backend/l3backend-pdfmode.def))
))
./Untitled.tex:4: Missing number, treated as zero.
<to be read again> 
                   s
l.4 ...vision[separators in work = false]{14.1}{3}

I'm not sure if I should contact the package author on something like this.

1

1 Answer 1

1

In longdivision.sty prior to version 1.2.0 (released during the lifetime of TeX Live 2020) there is no separators in work` option.

Update your TeX system. Possibly downloading the most recent version of longdivision from CTAN might work, if you want to wait for upgrading.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.