Hellou I'm running Ubuntu 20.04.4 LTS x86_64.

I previously had a TeXLive 2019 install on my machine via apt. But because of a problem with tlmgr (the Native TeXLive manager) concerning incompatible repository "versions", I wanted to perform a proper TeXLive install via the provided guide on https://tug.org/texlive/quickinstall.html.

So I sudo apt purge texlive-full in order to remove my TeXLive install and then proceeded with the quick-install from tug.org.

As it is now the install was successful (added everything into my PATH,MANPATH and INFOPATH). BUT the problem was still there.

Searching for a fix I ran the update-tlmgr-latest.sh script provided by my mirror https://ftp.rrzn.uni-hannover.de/pub/mirror/tex-archive/systems/texlive/tlnet/ which is up to date (Last modified on 17-Apr-2022 02:43). But I still get

wenigwil@kubuntboo:Downloads$ sudo tlmgr --verify-repo=none update --all
(running on Debian, switching to user mode!)

tlmgr: Local TeX Live (2019) is older than remote repository (2022).
Cross release updates are only supported with
  update-tlmgr-latest(.sh/.exe) --update
See https://tug.org/texlive/upgrade.html for details

with the emphasis on tlmgr: Local TeX Live (2019) is older than remote repository (2022).

, despite of

wenigwil@kubuntboo:Downloads$ tlmgr --version
tlmgr revision 63033 (2022-04-15 07:19:42 +0200)
tlmgr using installation: /usr/local/texlive/2022
TeX Live (https://tug.org/texlive) version 2022

I hope someone can help me with this issue.

  • 2
    Root has a different path to a normal user ...
    – Joseph Wright
    Jun 10, 2022 at 11:17
  • @JosephWright thank you for pointing that out. But if I run tlmgr update --self --all the manager tells me that "You don't have permission to change the installation in any way, [...] Please run this programm as administrator.". Jun 10, 2022 at 11:22
  • You need to add your TeX live install directory also to the sudo path. See superuser.com/q/927512 or unix.stackexchange.com/q/83191.
    – moewe
    Jun 10, 2022 at 11:24
  • 2
    Try sudo <full-path-to>/tlmgr ...
    – Joseph Wright
    Jun 10, 2022 at 11:24
  • 1
    Issuing sudo /usr/local/texlive/2022/bin/x86_64-linux/tlmgr update --self --all resulted in no error messages. It also stated that my package repository is verified which sounds great. Jun 10, 2022 at 11:29

1 Answer 1


personal experience:

1] delete tlmgr ==> which tlmgr ; and delete it, including its link if any

2] reinstall TexLive2022 (select scheme at least i: infrastructure-only scheme)

  • This is really not good advice. Deleting things your package manager installed is not a good idea. Take the time to manage the packages properly so this isn't necessary or, failing that, please don't recommend this to others. Aside from anything else, this will leave a bunch of other stuff in place and be undone whenever the package providing tlmgr gets updated.
    – cfr
    Aug 1 at 3:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .