I don't see a similar question so I'm posting this.

The file compiles fine if I delete [11pt] and let it default to 10pt.

  • I believe the format \documentclass[11pt][reqno]{amsbook} is correct
  • I believe 11pt is compatible with the document class amsbook
  • I did not read of a conflict between [regno] and typeface size

If it matters, the compiler is MikTex.

  • 3
    Write \documentclass[11pt,reqno]{amsbook} instead of \documentclass[11pt][reqno]{amsbook}. Commented Jun 10, 2022 at 17:35
  • 2
    To generalize the previous comments, options on \documentclass must all be enclosed in the same set of brackets [ ] and separated by commas. (The options you wish to use are both defined; it's the input format that's not correct.) Commented Jun 10, 2022 at 18:30
  • Thank you all. Clearly, I was wrong - the format is incorrect. If one you would like to post the clarification as an answer I'll be happy to check it and add a point. BTW, the entry in my list of commands for \documentstyle doesn't say anything about all the options being inside one set of [ ] separated by commas. How do you folks find out these things!
    – TonyK
    Commented Jun 10, 2022 at 19:04
  • any documentation that you have seen that said you could use [11pt] should have said what the syntax was, so the question is more where have you seen any suggestion that two options are possible there, we could get that documention fixed. Commented Jun 10, 2022 at 21:05
  • 1
    try learnlatex.org Commented Jun 11, 2022 at 0:02

1 Answer 1


The first optional argument of \documentclass takes a comma separated list of options.




If you enter



Then essentially LaTeX sees


and fails to find a class file with empty name.

With an old release (2019 or older) you get the error

 LaTeX Error: File `.cls' not found.

With a current release, you get several internal errors as the new filehooks code fails on the empty filename.

! LaTeX hooks Error: Missing (empty) default label on line 1.
(hooks)              This command was ignored.

Type <return> to continue.
l.1 \documentclass[11pt][r

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .