On Overleaf, I am using this type of bio:

Belinskii, A, & Klyshko, D. Two-photon optics: diffraction, holography, and transformation of two-dimensional signals. Sov. Phys. JETP 78, 259 (1994).
Pittman, T. B., Shih, Y. H., Strekalov, D. V. & Sergienko, A. V. Optical imaging by means of two-photon quantum entanglement. Phys. Rev. A 52, R34232 (1995).
Gatti, A., Brambilla, E., Bache, M. & Lugiato, L. A. Ghost Imaging with Thermal Light: Comparing Entanglement and Classical Correlation. Phys. Rev. Lett. 93,
093602 (2004).


When I cite \cite{GI, Pittman, Thermal} I'd like [1-3] but I get [1,2,3]. How can I change it?

  • You can get what you want either with \usepackage{cite} or with \usepackage[numbers, sort&compress]{natbib}. (Do not load both packages at the same time!) Since your manual thebibliography does not use the optional argument of \bibitem to pass on author and year data, it probably makes little sense to use natbib, so in your setting I'd go for \usepackage{cite}.
    – moewe
    Jun 16, 2022 at 15:17
  • Note that you need to escape your &s to \&s to avoid errors. Belinskii, A, should probably be Belinskii, A.,
    – moewe
    Jun 16, 2022 at 15:17


You must log in to answer this question.

Browse other questions tagged .