1

How can I change the default citation style in classicthesis to APA? I'm sure this has to be done in classicthesis-config.tex, specifically in the following snippet:

% ****************************************************************************************************
% 3. Loading some handy packages
% ****************************************************************************************************
% ********************************************************************
% Packages with options that might require adjustments
% ********************************************************************
\PassOptionsToPackage{ngerman,american}{babel} % change this to your language(s), main language last
% Spanish languages need extra options in order to work with this template
%\PassOptionsToPackage{spanish,es-lcroman}{babel}
    \usepackage{babel}

\usepackage{csquotes}
\PassOptionsToPackage{%
  %backend=biber,bibencoding=utf8, %instead of bibtex
  backend=bibtex8,bibencoding=ascii,%
  language=auto,%
  style=numeric-comp,%
  %style=authoryear-comp, % Author 1999, 2010
  %bibstyle=authoryear,dashed=false, % dashed: substitute rep. author with ---
  sorting=nyt, % name, year, title
  maxbibnames=10, % default: 3, et al.
  %backref=true,%
  natbib=true % natbib compatibility mode (\citep and \citet still work)
}{biblatex}
    \usepackage{biblatex}

Can I somehow "force" the use of apacite? If so, how?


EDIT: In classicthesis-config.tex, I changed the snipplet to:

% ****************************************************************************************************
% 3. Loading some handy packages
% ****************************************************************************************************
% ********************************************************************
% Packages with options that might require adjustments
% ********************************************************************
\PassOptionsToPackage{ngerman,american}{babel} % change this to your language(s), main language last
% Spanish languages need extra options in order to work with this template
%\PassOptionsToPackage{spanish,es-lcroman}{babel}
    \usepackage{babel}

\usepackage{csquotes}
\PassOptionsToPackage{%
  backend=biber,
  style=apa,
  natbib=true % natbib compatibility mode (\citep and \citet still work)
}{biblatex}
\usepackage{biblatex}

And in ClassicThesis.tex in line 114, I added \printbibliography:

%********************************************************************
% Other Stuff in the Back
%*******************************************************
%\cleardoublepage\include{FrontBackmatter/Bibliography}
\printbibliography
\cleardoublepage\include{FrontBackmatter/Declaration}
\cleardoublepage\include{FrontBackmatter/Colophon} 

The command \addbibresource{Bibliography.bib} is also included.

After doing this, citations stopped showing, e.g.:

broken-cite

and the bibliography isn't showing anymore. I am compiling using the following MakeFile:

ClassicThesis.pdf: Bibliography.bib ClassicThesis.tex classicthesis-config.tex Chapters/*.tex FrontBackmatter/*.tex
    pdflatex -shell-escape ClassicThesis
    biber ClassicThesis
    pdflatex -shell-escape ClassicThesis
    pdflatex -shell-escape ClassicThesis

partial:
    biber ClassicThesis
    pdflatex -shell-escape ClassicThesis

clean:
    rm -f *.lot *.tps *.tcp *.lof *.xml *.lol *.toc *.log *.out *.aux *.blg *.bbl Chapters/*.aux FrontBackmatter/*.aux

What's the problem and how can I fix it?


EDIT 2: Here's the content of ClassicThesis.blg:

[0] Config.pm:304> INFO - This is Biber 2.12
[0] Config.pm:307> INFO - Logfile is 'ClassicThesis.blg'
[48] biber-darwin:315> INFO - === Sat Jun 18, 2022, 08:43:49
[78] Biber.pm:371> INFO - Reading 'ClassicThesis.bcf'
[205] Biber.pm:889> INFO - Found 0 citekeys in bib section 0
[205] Biber.pm:886> INFO - Using all citekeys in bib section 1
[207] Biber.pm:889> INFO - Found 26 citekeys in bib section 0
[235] Biber.pm:4093> INFO - Processing section 0
[250] Biber.pm:4254> INFO - Looking for bibtex format file 'Bibliography.bib' for section 0
[252] bibtex.pm:1523> INFO - LaTeX decoding ...
[291] bibtex.pm:1340> INFO - Found BibTeX data source 'Bibliography.bib'
[470] UCollate.pm:68> INFO - Overriding locale 'en-US' defaults 'variable = shifted' with 'variable = non-ignorable'
[471] UCollate.pm:68> INFO - Overriding locale 'en-US' defaults 'normalization = NFD' with 'normalization = prenormalized'
[471] Biber.pm:3921> INFO - Sorting list 'apa/global//global/global' of type 'entry' with template 'apa' and locale 'en-US'
[471] Biber.pm:3927> INFO - No sort tailoring available for locale 'en-US'
[502] Biber.pm:4093> INFO - Processing section 1
[502] Biber.pm:4254> INFO - Looking for bibtex format file 'AMiede_Publications.bib' for section 1
[503] Utils.pm:209> ERROR - Data file 'AMiede_Publications.bib' cannot be read in encoding 'utf8': Can't decode ill-formed UTF-8 octet sequence <C4> at /var/folders/8c/st4skfzn1rz9_wx_30trp0zh0000gn/T/par-757365723135353033/cache-4a15ba093415e07429811691e581a80d4a83c13b/inc/lib/File/Slurper.pm line 63.
[503] Biber.pm:114> INFO - ERRORS: 1
7
  • Now there’s no way to help without you constructing a small sample document that shows the problem. Did you run the clean option of your makefile first? And what kind of citation commands are you using? Are there errors when you compile?
    – Alan Munn
    Jun 18, 2022 at 1:59
  • @AlanMunn I'm using the standard classicthesis package which I linked above, I haven't made any changes to it, i.e it can be used to reproduce the problem.
    – Monika
    Jun 18, 2022 at 2:01
  • The partial compilation instruction looks a bit odd, but the complete compile should work. If you ran that there should be a .blg file (a simple text file, even if Windows systems sometimes classify it as a "performance monitor file"). Show us the complete contents of that file.
    – moewe
    Jun 18, 2022 at 6:16
  • @moewe I edited my question and included the .blg file, it seems to be an encoding problem(?)
    – Monika
    Jun 18, 2022 at 6:47
  • 2
    Argh. Forget what I said. Somewhere in your code there is a \addbibresource[label=ownpubs]{AMiede_Publications.bib} (or maybe only \addbibresource{AMiede_Publications.bib}). Remove that line.
    – moewe
    Jun 18, 2022 at 6:50

1 Answer 1

3

Here's what you need to change:

\PassOptionsToPackage{%
  backend=biber,
  style=apa,
%  natbib=true % natbib compatibility mode (\citep and \citet still work)
}{biblatex}
\usepackage{biblatex}

Uncomment the natbib=true if you're used to using natbib and want to continue using its citation commands. But it's probably better to get used to the proper biblatex commands.

Note that this is not using apacite which is a different package which uses bibtex for processing the bibliography, not biber, and uses the apacite bibliography style.

In your main document you would use:

\addbibresource{yourbibfile.bib} % .bib extension required

and

\printbibliography
1
  • Thank you! This prevents citations from showing, please see my edited post.
    – Monika
    Jun 18, 2022 at 1:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .