I would like to insert "ç". Tried including \usepackage[utf8]{inputenc}, and type \c {c} , but doesn't work.

  • you don't say how this doesn't work, so i'm guessing. if you redefined \c you would get either an error or surprising output; i'd check for that first. but of course if you have the letter on your keyboard, it's easiest to use that if you're using inputenc with an appropriate option. – barbara beeton Jul 27 '12 at 12:28

If you load inputenc with the utf8 encoding option (make sure that your editor is also configured to use Unicode), you can input those characters directly from your keyboard:


Ç et ç

enter image description here

A few comments (added by herve):

If your keyboard has not a french layout, the way to input it are (on a mac using international keyboard: alt+c , on a linux box compose followed by coma followed by c.

\c c should work without use of \usepackage[utf8]{inputenc}.

| improve this answer | |
  • Thanks, problem solved. I have some conflicts between packages(I guess.) I further added \usepackage[T1]{fontenc} and it finally works. I don't know why though. I typed ç directly in the text. – user16739 Jul 27 '12 at 3:15
  • 1
    Adding \usepackage[T1]{fontenc} to your preamble is a good thing, but sadly it will load a bitmap font by default. To fix this, you should install the cm-super package or load a vector font. – matth Jul 27 '12 at 8:57
  • You are right. The whole text is changed. I don't know what to do now. – user16739 Jul 27 '12 at 15:22
  • @user16739 It's hard to tell without seeing your actual settings. Perhaps you should open a fresh new question showing a minimal and complete version of your document illustrating the problem. Since the issue of the original question was solved, I don't see why you un-accepted the answer. You can always start follow-up questions for new issues. – Gonzalo Medina Jul 27 '12 at 15:29
  • It's not solved.\usepackage[french]{babel} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc}--those three package couldhelp insert ç, but they also change the other English characters. If I omit one package, error occurs. – user16739 Jul 27 '12 at 15:33

Simply \c{c}, no space.

I believe you are trying a space between \c and {c}.

| improve this answer | |
  • Welcome to TeX.sx! Feel free to visit our TeX.SX starter guide to get the most of our site. – Peter Jansson May 16 '13 at 7:30
  • 5
    This can't be the problem: space after command sequences is automatically gobbled. \c c, \c {c}, and \c{c} are treated the same (provided '`', 'c', '{', '}', and ' `' have the usual catcodes). – Charles Stewart May 16 '13 at 8:16

On Mac the following works fine:


Ç ç é É üäö
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.