I want to test this template http://students.engr.scu.edu/~sschaeck/latexforthesis/.

when i run the makefile i get this error .Please what does it mean this error

here the code :

\documentclass[12pt]{thesis} %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

%%% preample %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

%%% packages %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\usepackage[T1]{fontenc}        % euro quality fonts [T1] (togeth. w/ textcomp)
\usepackage{textcomp, amssymb}  % additional symbols (there are more packages)
\usepackage[latin1]{inputenc}   % umlaute in input file
\usepackage{setspace}           % doublespacing
\usepackage{anysize}            % margin package sets tighter margins
\usepackage[all]{xy}            % creating figures within latex
\usepackage[tight]{subfigure}% subfigures: figures within figures

%\marginsize{1.2in}{0.9in}{1.1in}{0.9in} % small margins
\marginsize{1.2in}{0.9in}{0.5in}{1.5in} % small margins

\usepackage{ifpdf}              % if pdflatex then ... else ...
  \pdfadjustspacing=1           % make pdflatex behave like latex
  \usepackage{aeguill}          % PS converted CM fonts for better acro preview
  \usepackage[pdftex]{graphicx} % graphics packages
  \usepackage[pdftex]{color}    % color packages
  \usepackage[pdftex]{thumbpdf} % create thumbnails (run thumbpdf as well)
              pagebackref=true, % bibliography -> text
              linktocpage=true, % toc etc: make page number active (not name)
              plainpages=false, % distinguish roman and arabic pagenumbers
              pdfauthor={Stefan Sch�ckeler},%
              pdftitle={Lorem Ipsum Dolor Sit Amet},% 
              pdfsubject={PhD Thesis},%
              pdfkeywords={Embedded Systems, Code Compaction},%
             ]{hyperref}        % clickabe references
              plainpages=false, % distinguish roman and arabic pagenumbers
              linktocpage=true, % toc etc: make page number active (not name)
             ]{hyperref}        % clickabe references in .dvi
                                % purposely included before color package
  \usepackage[dvips]{color}     % color packages; needed by xy
  \usepackage[dvips]{graphicx}  % graphics packages

% hyperref must be the second last package and glossary the last package

% index
\usepackage{makeidx}                       % for \printindex
\makeindex                                 % creates paper.idx index file

% glossary
\usepackage[style=super, cols=3]{glossary} % for \printclossary
\makeglossary                              % creates paper.glo glossary file

%%% style and finetuning %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\pagestyle{plain}               % pagestyle: headings, empty, plain

% new theorems

%%% document %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%


\pagenumbering{roman} % titlepage does not get a number - that's odd, but good.

\ifpdf\pdfbookmark[1]{Title}{label:title}\fi              \input{titlepage.tex}

\newpage                                                     \input{spruch.tex}

\newpage\ifpdf\pdfbookmark[1]{Abstract}{label:abst}\fi     \input{abstract.tex}

\newpage\ifpdf\pdfbookmark[1]{Table of Contents}{label:toc}\fi \tableofcontents
\newpage\ifpdf\pdfbookmark[1]{List of Figures}{label:lof}\fi     \listoffigures
\newpage\ifpdf\pdfbookmark[1]{List of Tables}{label:lot}\fi       \listoftables



% Bibliography and Glossary          (\phantomsection is needed for hyperlinks)

\addcontentsline{toc}{chapter}{\bibname}              % add Bibliography to TOC

\addcontentsline{toc}{chapter}{\indexname}                   % add Index to TOC

\addcontentsline{toc}{chapter}{Glossary}                  % add Glossary to TOC



the error it at the else .

Package thumbpdf Warning: Thumbnail data file `thesis.tpt' not found.

! TeX capacity exceeded, sorry [input stack size=5000].
\curr@fontshape ->\f@encoding 
                              /\f@family /\f@series /\f@shape 
l.38 \else

If you really absolutely need more capacity,
you can ask a wizard to enlarge me.

Here is how much of TeX's memory you used:
 4193 strings out of 495285
 52396 string characters out of 3180406
 331427 words of memory out of 3000000
 7339 multiletter control sequences out of 15000+200000
 7342 words of font info for 24 fonts, out of 3000000 for 9000
 14 hyphenation exceptions out of 8191
 5000i,0n,9994p,231b,80s stack positions out of 5000i,500n,10000p,200000b,50000s
!  ==> Fatal error occurred, no output PDF file produced!
  • I don't get any error, only a warning about an open brace without the matching one (it's before one \doublespacing command).
    – egreg
    Commented Jul 27, 2012 at 12:57
  • Hi ,:( i don't know why does not work for me do you think this is a problem with Texmaker editor? please can you try with PdfLaTex
    – WOW
    Commented Jul 27, 2012 at 13:07
  • @WOW - I don't get a "TeX capacity exceeded" error message either when I try to compile this file under pdflatex, running TeXLive2012. Which TeX distribution do you use?
    – Mico
    Commented Jul 27, 2012 at 13:31
  • I did try with pdflatex.
    – egreg
    Commented Jul 27, 2012 at 13:36
  • Mico I use Miktex.
    – WOW
    Commented Jul 27, 2012 at 13:40

8 Answers 8


I get the same error with MikTeX 2.9, WinEdt 7 on Win 7. There is an undefined char (german umlaut?) in the pdfauthor property. If you remove/replace this character LaTeX runs until the \newtheorem{example}{Example} definition. Here one get the error that \example is already defined. Rename it and LaTeX compiles the whole document.


I'm getting Error Latex TeX capacity exceeded, sorry [input stack size=5000] in a beamer document when I try to make a block without a title and starting with an itemize environment:

This fails:

\begin{frame}{About Foo}
            \item foo

This works:

\begin{frame}{About Foo}
            \item foo

Note the extra {} after the \begin{block}.


I had this happen and the problem was a statement like this:


Internally, somewhere else, the yen symbol was being mapped to \textyen. That of course made an endless loop

(gripe-on)The lack of a good error message that includes the exact symbol that it was processing at the time, or the exact line number of the file that it found it in, makes these problems many times more difficult to find/solve than they should be.(gripe-off)

  • 1
    Is this an answer or a new question?
    – egreg
    Commented Jan 16, 2016 at 11:25
  • It is supposed to be an answer. I clarified that by replacing the rhetorical question with a statement.
    – AgilePro
    Commented Jan 17, 2016 at 17:21
  • 1
    I also had this error due to a infinite loop. Adding it here because I like the idea of this page becoming the "all possible ways to get this error" page. I was using a \renewcommand\thetable{\thetable.\arabic{table}} instead of \renewcommand\thetable{\thechapter.\arabic{table}}.
    – Soltius
    Commented Mar 5, 2021 at 10:02

I've got a similar problem when trying to include a previous text I wrote to a new latex project. In my case I found it was due to the size of the caption text of the figures. I reduced the amount of text inside the caption and it worked.


I just solved the same error.

The cause of this problem is the file of "XXX.sty".

The "XXX.sty" file I used is damaged. When I replace it with another one, the problem is resolved.

You can try.

  • 6
    Is it a damaged file, or a defective version? If the latter, perhaps tell us the name of the problem sty file.
    – Stefan Kottwitz
    Commented Apr 30, 2014 at 7:53

For me, the problem occured when I added a citation to my literature.bib which included an abstract with multiple %-symbols. I had to delete the .bbl file and escape \% the symbols which had also caused some other problems.

By the way, here you can find even more answers to the problem. I can't post there, yet. Otherwise, I would have.

  • 1
    First: thanks! I just want to confirm to check up on things like this even if it seems unreasonable. In fact that solved my problem in a case where I added an new citation to my *.bib which went just fine before, while the catch is that the "%" has been there in another entry all the time without making any problems but it started to do after adding a completely unrelated new entry. There surely is a reason, I just don't know which.
    – Wolfone
    Commented Apr 6, 2019 at 11:25
  • Thank you! Glad I could help!
    – Christian
    Commented Oct 10, 2019 at 16:43

In my case, this problem and a variety of other, rather erratic failures were apparently caused by using "\%" in Figure captions and legends. After replacing "\%" by "percent" everything ran smoothly again. (Thanks to Christian for pointing to "%" symbols as potential troublemakers!)

  • 2
    It would be far better if you can produce code that allows future users to replicate your problematic behaviour. It also allows one to test your solution to confirm under which cases it works. Can you do that?
    – Werner
    Commented Mar 11, 2020 at 5:10

Kept happening to me on the second build of a large project (the first call to pdflatex ran without error). The error was very strange as commenting out completely separate parts of text (without commands) would solve the issue. Hence creating an MWE seemed really impossible as randomly commenting in/out separate parts of the document would give seemingly random results. Eventually I figured it was probably due to some sort of awkward page-break causing the issue.

To debug I started adding commands like:


... to temporarily disable some reference-type commands I figure might have issues with a nasty page-break. Putting back in all of the rest of the text I had commented out, there was no problem. Slowly removing the above commands, I found that \footnote (or something inside it) was problematic. So I left the command in and started to work on removing some long footnotes that looked like they might be troublesome. I never figured out which particular footnote or footnotes were the issue, but the error disappeared. Again I'm figuring it perhaps had to do with not being able to fit the footnotes on one page, or breaking footnotes across pages, or breaking something inside a footnote across pages, something along those lines.

Nasty one. Lost a lot of time on this so posting my strategy in case it might help someone in the same boat.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .