5

I'm using ConTeXt to typeset a long document, and I'm using the libertinus font. However, \mathcal{A} produces 𝒜 rather than a calligraphic 'A', like it does with other fonts. I can get a good looking calligraphic set from either Asana Math or Euler, but I can't seem to switch between fonts. Trying to modify the example from the wiki to use libertinus,

\definefallbackfamily[mainface][math][Euler][range={uppercasescript,lowercasescript}]

\definefontfamily [mainface] [rm] [libertinusserif]
\definefontfamily [mainface] [math] [libertinusmath]

\setupbodyfont[mainface]

doesn't actually seem to use the Euler font at all, and switching Euler other font's don't either. Looking in the log, there is a line:

the requested fallback font 'euler' for typeface 'mainface' style 'mm' was ignored because no files where found.

I tried specifying files manually, which didn't change that result at all.

I have also tried making a \altmathcal macro which switches body fonts, but that seems to have no effect.

How can I use libertinus everywhere except \mathcal?

1
  • The libertinus math font does not seem to have a calligraphic alphabet, and then both \mathcal and \mathscr gives the script alphabet. The only unicode fonts that have both chancery and roundhand that I know of are lucida, stix two and xits. That does not help you much, though, but now you know why you get what you get.
    – mickep
    Commented Jul 9, 2022 at 19:51

1 Answer 1

1

Well, I have a partial solution.

\definefallbackfamily[mainface][mm][newcomputermodernmath][range={uppercasescript,lowercasescript},force=yes]
\definefontfamily [mainface] [rm] [libertinusserif]
\definefontfamily [mainface] [math] [libertinusmath]

works for reasons I cannot divine, but I'm happy enough with the calligraphic characters from it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .