0

For my thesis, I need to present the references in full as footnotes every time the document is presented in the text.

For that, I've been using BibLatex with the following options:

\usepackage[backend=biber,style=apa,language=english]{biblatex}

In the text, when necessary, insert a reference, the command I'm using is \footfullcite{ref}. However, sometimes I need to insert multiple references in the same footnote, and for that, the command is \footfullcite{ref1,ref2,ref3}.

It works perfectly when I'm referencing articles.

The problem is when I need to indicate the page of the document, like a book. The command \footfullcite[p. x]{ref} works perfectly when only one reference is indicated, but when indicating multiple references, I can't indicate the page for one specific reference.

If I try to use the command \footfullcite[p. x]{ref1,ref2,ref3}, the number of the page appears at the end of all references, independently of which works it refers to.

I have tried to adapt a solution like the one present here, but it didn't work.

A MWE of what I'm trying:

\begin{filecontents*}{\jobname.bib}
    @article{test,
        title = {Synthesis of Enantiopure Alcohols},
        volume = {71},
        number = {17},
        journal = {J. Org. Chem.},
        author = {Test T.},
        month = aug,
        year = {2006},
        pages = {6333--6445}
    }
\end{filecontents*}
\documentclass[12pt, a4paper, twoside, english]{abntex2}
\usepackage[backend=biber]{biblatex}
\addbibresource{\jobname.bib}
\begin{document}
    First\footfullcite{test}, second\footfullcite{test} and third time.\footfullcite{test}
    Multiple times.\footfullcite{test,test,test}
    Multiple times with page number.\footfullcite[p. 15]{test,test,test}
    \end{document}

The result is:

enter image description here

However, I would like to insert the page number on the second reference, for example, and not at the end of all references.

Could someone please help me? Thank you!!

PS: On my system, I'm using the command \usepackage[backend=biber,style=apa,language=english]{biblatex}, but for some reason I don't know, when I try to use this command in the MWE, the references don't appear correctly.

2
  • See multicite in the biblatex manual (texdoc biblatex).
    – Cicada
    Aug 1, 2022 at 15:04
  • @Cicada thanks for the tip, but unfortunately it didn't help much. The multicite options don't work in my case, as there's not a multicite version of \footfullcite. If I try to use the \footcitetexts command, I am able to insert the number of the page correctly linked with the work I choose. But this option does not provide me the full information of the references, as I need. Aug 2, 2022 at 16:17

2 Answers 2

2

You can use multicite commands to give multiple citations with separate postnote (page ranges). By default there is no multicite version of \footfullcite, presumably because it was not envisioned that \footfullcite would be your go-to citation command, but it is not too hard to make a multicite version of it

\documentclass[british]{article}
\usepackage[T1]{fontenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[backend=biber, style=apa]{biblatex}

% just for the example
\AtEveryCitekey{\clearfield{annotation}}

\DeclareMultiCiteCommand{\footfullcites}[\mkbibfootnote]{\footfullcite}{\multicitedelim}

\addbibresource{biblatex-examples.bib}

\begin{document}
Lorem \footfullcites[380]{sigfridsson}[12]{worman}[51]{geer}

\printbibliography
\end{document}

Sigfridsson, E., & Ryde, U. (1998). Comparison of methods for deriving atomic charges from the electrostatic potential and moments. Journal of Computational Chemistry, 19(4), 377–395. https://doi.org/10.1002(SICI)1096-987X(199803)19:4<377::AID-JCC1>3.0.CO;2-P p. 380; Worman, N. (2002). The cast of character: Style in Greek literature. University of Texas Press, p. 12; Geer, I. de. (1985). Earl, saint, bishop, skald – and music: The Orkney Earldom of the twelfth century. A musicological study [Doctoral dissertation, Uppsala Universitet]. Uppsala, p. 51

0

The solution I found:

Although the BibLaTeX manual refers that by default it will not sort citations if multiple entry keys are passed to a citation command, it kept sorting the entries cited following the default sorting for the bibliography (NTY).

To change that, I had to force it to disregard any sorting order, adding the option sortcites=false.

Now the BibLateX is called with the following options:

\usepackage[backend=biber,style=apa, sortcites=false, language=english]{biblatex}

This allows me to keep using the \footfullcite command, and I just have to order the entries cited in order to leave the one that will present the page number as the last.

The command will be \footfullcite[p. 15]{test1,test2,test3} to insert the page number to the reference #3, or \footfullcite[p. 15]{test3,test2,test1} to insert the page number to the reference #1.

I am aware that this is not a complete solution, as if it is necessary to insert different page numbers to different entries, this solution will not work.

2
  • 1
    While it is the biblatex core default to have sortcites=false,, styles you load may change this. style=apa, sets sortcites=true, overriding the biblatex core default.
    – moewe
    Aug 2, 2022 at 19:42
  • Thank you very much @moewe for your comment and elegant solution. It helped a lot! Aug 3, 2022 at 11:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .